WirelessInfo.be informatie over bedrade en draadloze netwerken
Mikrotik USB-stick in gebruik stellen voor externe opslag Mikrotik logo

Mikrotik USB-stick in gebruik stellen voor externe opslag

Routerboard RouterOs Bios firmware
RB3011 UiAS-RM 6.39rc13 3.35

Daar de storage op de Mikrotik devices beperkt is, kan je de routerboards die voorzien zijn van SD / CF / en USB-slots van extra storage (opslag) voorzien. Ik toon hier de installatie van een Sandisk Ultra USB 3.0 32 gigabyte USB-stick als externe opslag media. Dit kan gebruikt worden onder andere voor Dude files, en voor transparante proxy bestanden op te slaan en zo meer. Sinds RouterOs 6.20 is de "disk/store menu verplaatst naar "system" "disk" in het hoofd menu. In deze menu zal al de aangesloten ondersteunende opslag media worden getoond.

usb-stick

Als voorbeeld neem ik het RB3011 UiAS-RM. Plug de USB-stick in de daar voorziene USB-poort.

usb-stick

Klik in het hoofd menu op "system" vervolgens op "disk".

usb-stick

KLik op "format drive", soms kan het zijn dat je eerst op "eject drive" moet klikken.

usb-stick

Bij "label" geef de USB-stick een naam, klik vervolgens op "start" om het formateren te starten.

usb-stick

Het formateren is begonnen, dit kan enkele minuten duren afhankelijk van de grote van de disk.

usb-stick

Na het formateren zie je dat de disk tevoorschijn komt, dit kan je ook nagaan in "new terminal".

usb-stick

In het hoofd menu klik op "new terminal".

usb-stick

Schrijf nu "disk print" en druk op "enter". Je ziet dat de disk perfect geinstalleerd is. Nu moeten we nog de disk koppelen aan een programma.

Top

De disk koppelen voor gebruik met de dude.

usb-stick

In "new terminal" geef je nu in: "/dude set data-directory=Ultra/dude-data".

usb-stick

Op deze screenshot kan je zien dat de data van de dude op de USB-stick (ultra) wordt weggeschreven.

Voor syslog.

usb-stick

Formateer de USB-stick of andere data opslag media, geef deze het label "log-storage".

usb-stick

Ga naar het hoofd menu naar "new terminal" voer daar het volgend kommando in: /system logging action set disk disk-file-name=/Ultra/log/syslog

usb-stick

Terug in het hoofd menu klik je op "system" "logging".

usb-stick

Klik op "action" vervolgens op "disk".

usb-stick

Dubbelklik op "disk". Selecteer bij "Type" "disk" en klik op "ok". De logfiles worden nu op de USB-stick opgeslagen.

usb-stick

Klik op "rules" dubbelklik op "info" en selecteer in plaats van "memory" "disk", klik op "ok". Doe dat bij al de log onderwerpen.

usb-stick

Als je nu naar "log" gaat gaan kijken staan die daar te zien vanaf de disk wat wil zeggen de USB-stick.

Voor user manager en voor proxy-server kan je dit ook en is ook een kwestie van selecteren waar de data moet op geplaatst worden. Ik geef wel nog de commando's mee.

Voor user manager. Niet alle routerboards ondersteunen user manager zoals ARM, MMIPS.

/tool user-manager database set db-path=Ultra/cache-n-db/user-manager/

Voor proxy server.

/ip proxy set cache-path=Ultra/cache-n-db/proxy/

usb-stick

Deze routerboards komen zeker in aanmerking voor de externe opslag maar er zijn er nog andere ook. De bovenste het Hex RB750 Gr3 is voorzien van een micro sd.

usb-stick

Je kan meerdere opslag media gebruiken en aansluiten op voorwaarde dat je een powered USB-hub gebruikt. Hieronder zie je een USB 3.0 usb hub met twee Sandisk USB-sticks van 32 gigabyte. Maar je kan er een externe harde schijf inpluggen ook voor een nog grotere capaciteit.

Top