WirelessInfo.be informatie over bedrade en draadloze netwerken
Mikrotik tool netwatch switchen tussen twee gateways door uitschakelen van EOIP-tunnel Mikrotik logo

Mikrotik tool netwatch

Mikrotik tool netwatch switchen tussen twee gateways door uitschakelen van EOIP-tunnel

Met netwatch kan je hosts op het netwerk monitoren. Netwatch doet dit door middel van ICMP-pings te sturen naar de in de lijst opgegeven IP-adressen. In dit voorbeeld heb ik twee internet gateways die zijn verbonden met het routerboard door middel van EOIP-tunnels. Als netwatch gateway 1 niet meer kan pingen gaat de EOIP-tunnel 1 uitgeschakeld worden. EOIP-tunnel 2 gaat vervolgens ingeschakeld worden om de internet gateway 2 bereikbaar te maken. Als internet gateway 1 terug online is gaat netwatch terug de internet gateway 1 bereikbaar maken door de EOIP-tunnel 1 aan te schakelen en EOIP-tunnel 2 terug uit te schakelen.

Dit script is getest en werkend met volgende RouterOs

RouterOs Bios firmware
6.27 3.22

Script netwatch-switch gateway
  • /tool netwatch
  • add comment="eoip1" down-script=\
  • "/interface eoip disable eoip1" host=10.10.10.10 interval=10s \
  • up-script="/interface eoip enable eoip1"
  • add comment="eoip2" down-script=\
  • "/interface eoip enable eoip2" host=10.10.10.10 interval=10s \
  • up-script="/interface eoip disable eoip2"

Kopieer het script. Opgelet vergeet de rood gekleurde text niet aan te passen aan de configuratie van uw routerboard.

netwatch

Open "new terminal" en plak het bewerkte script in het venster.

netwatch

Eens een kijkje nemen. Klik in het hoofdvenster op "tool" vervolgens op "netwatch".

netwatch

Hier zie je de twee netwatch opdrachten die je hebt aangemaakt.

netwatch

Bij "EOIP1" "UP" zie je dat EOIP-tunnel 1 ingeschakeld wordt als de internet gateway 1 bereikbaar is.

netwatch

Bij "EOIP1" "DOWN" zie je dat EOIP-tunnel 1 uitgeschakeld wordt als de internet gateway 1 niet bereikbaar is.

netwatch

Bij "EOIP2" "UP" zie je dat EOIP-tunnel 2 uitgeschakeld wordt als de internet gateway 1 bereikbaar is.

netwatch

Bij "EOIP2" "DOWN" zie je dat EOIP-tunnel 2 ingeschakeld wordt als de internet gateway 1 niet bereikbaar is. Dan is internet gateway 2 bereikbaar en heb je terug internet via een ander netwerk.

Top