WirelessInfo.be informatie over bedrade en draadloze netwerken
Mikrotik failover met behulp van netwatch Mikrotik logo

Mikrotik failover met behulp van netwatch

RouterOs Bios firmware
6.37.4 3.34

In dit voorbeeld gebruik ik de Hap AC RB962UiGS-5HacT2HnT. Ik begin de configuratie vanaf niets om het u zo duidelijk en volledig mogelijk te kunnen tonen.

Hap AC RB962UiGS-5HacT2HnT

De bedoeling van deze configuratie is om internet te blijven houden bij uitval van uw eerste internet provider (ISP1). Bij het offline gaan van ISP1 gaat ISP2 internet gaan aanbieden door een routing configuratie te veranderen.

Dit door middel van een script dat netwatch zal draaien. Als ISP1 terug online komt veranderd netwatch de route setup en komt internet terug via ISP1.

Wat doet netwatch in deze configuratie?

Netwatch pingt een bepaalt IP-adres via de modem of router van ISP1. Door een firewall rule wordt het pingen via de modem of router van ISP2 geblokkeerd. Op deze manier kan netwatch zien of internet bereikbaar is via ISP1 of niet. Kan netwatch het ingegeven IP-adres niet meer pingen, Draait netwatch een script dat de afstand in de routing instelling veranderd. Kan netwatch het ingesteld IP-adres terug pingen, draait netwatch terug het script en veranderd terug de afstand van de routing configuratie zodat ISP1 voorrang krijgt.

Opgelet! Deze configuratie doet niet aan load balancing, die zorgt er wel voor dat de internet toegang met behulp van 2 ISP's (uw Internet Service Providers) niet offline gaat. Bij de switching van ISP1 naar ISP2 of omgekeerd kan een kleine uitval gebeuren omdat de router terug de route moet berekenen om het internet te bereiken, maar dit gaat over enkele seconden.

Ik start met een lege configuratie om het u gemakkelijk en duidelijker te maken. Je moet dus de router resetten zonder standaard configuratie. Als je de standaard configuratie wil gebruiken kan je deze instellingen overslaan.

Het accesspoint configureren

Hap AC RB962UiGS-5HacT2HnT

Open winbox en klik op het routerboard om de configuratie te beginnen, klik in het hoofdmenu op "interfaces" dubbelklik vervolgens op "ether1". Geef deze de naam "ether1_isp1" en klik links op "comment".

Hap AC RB962UiGS-5HacT2HnT

Geef in het venster bij "comment" de naam "isp1", klik op "ok" en sluit door nogmaals op "ok" te drukken. Doe dit ook zo bij ether2 maar geef deze de naam "ether2_isp2". Klik vervolgens op "comment" geef de naam "isp2" druk op "ok", sluit door nogmaals op "ok" te drukken.

Hap AC RB962UiGS-5HacT2HnT

Je kan dit vervolgens bij alle interfaces doen zodat alles duidelijk is, zodat je later nog weet welke interface bij wat hoort.

Hap AC RB962UiGS-5HacT2HnT

Klik in het hoofdmenu op "dhcp", klik vervolgens op dhcp-client.

Hap AC RB962UiGS-5HacT2HnT

Klik op het blauwe kruisje.

Hap AC RB962UiGS-5HacT2HnT

Selecteer "ether1_isp1" klik op "ok". Doe met de ether2_isp2 interface hetzelfde.

Hap AC RB962UiGS-5HacT2HnT

Deze gaan verbinden met uw twee isp modems. Daarom gaan we voor de veiligheid de automatische discovery op deze interfaces afzetten. Want deze komen in contact met het externe netwerk WAN genoemd.

Hap AC RB962UiGS-5HacT2HnT

KLik op "ip" vervolgens op "neighbors".

Hap AC RB962UiGS-5HacT2HnT

Klik op het tabblad "discovery interfaces".

Hap AC RB962UiGS-5HacT2HnT

Selecteer "ether1_isp1 en ether2_isp2 en klik op het rode kruisje voor die te disablen. Zo van buiten het netwerk (internet) kan men de interfaces niet meer opsporen met de discovery tool van Mikrotik.

Hap AC RB962UiGS-5HacT2HnT

De overige interfaces zijn de LAN interfaces, dit zijn de interfaces waar je uw PC, laptop, en draadloze toestellen kunt mee verbinden. Ik ga tonen hoe je die interfaces in switch modus zet. Dubbelklik daarvoor op "interfaces" ether5_lan.

Hap AC RB962UiGS-5HacT2HnT

Selecteer nu bij "master port" "ether3_lan".

Hap AC RB962UiGS-5HacT2HnT

Doe dit voor "ether4_lan ook, dubbelklik op de interface.

Hap AC RB962UiGS-5HacT2HnT

Selecteer terug bij "master port" ether3_lan. Klik op "ok" en sluit het venster.

Hap AC RB962UiGS-5HacT2HnT

In het hoofdmenu klikt u vervolgens op "bridge". Klik op het blauwe kruisje.

Hap AC RB962UiGS-5HacT2HnT

Bij "name" geef de bridge een naam, bijvoorbeeld "bridge_local.

Hap AC RB962UiGS-5HacT2HnT

Klik nu op het onderkopje "port" om interfaces aan de bridge toe te voegen.

Hap AC RB962UiGS-5HacT2HnT

Klik op het blauwe kruisje en selecteer de master port "ether3_lan", klik op "ok".

Hap AC RB962UiGS-5HacT2HnT

Vervolgens klik op het blauwe kruisje om nu de wireless interfaces toe te voegen. Selecteer "wlan1" en klik op "ok".

Hap AC RB962UiGS-5HacT2HnT

Vervolgens klik nogmaals op het blauwe kruisje om nu wlan2 toe te voegen. Selecteer "wlan2" en klik op "ok". Alle interfaces zijn aan de bridge toegevoegd. Vervolgens moet de bridge een IP-adres krijgen.

Hap AC RB962UiGS-5HacT2HnT

Klik op "IP" vervolgens op "addresses"

Hap AC RB962UiGS-5HacT2HnT

Selecteer bij "interfaces" "bridge_local".

Hap AC RB962UiGS-5HacT2HnT

Geef het door u gewenste IP-adres in bijvoorbeeld 192.168.100.1/24. Die /24 is het subnetmasker 255.255.255.0 want dit wordt de IP-pool voor de LAN. Klik op "ok".

Hap AC RB962UiGS-5HacT2HnT

Zo het IP-adress is aan de bridge gekoppeld.Nu toon ik hoe een DHCP-server in te stellen, die gaat ervoor zorgen dat iedere computer, laptop, smartphone en zo meer een eigen IP-adres gaat toegekent krijgen door de DHCP-server.

Hap AC RB962UiGS-5HacT2HnT

Klik op het hoofdmenu terug op "IP" vervolgens op "DHCP-server". Nu volgt de "next" fase van de DHCP setup.

Hap AC RB962UiGS-5HacT2HnT

Klik op "DHCP Setup".

Hap AC RB962UiGS-5HacT2HnT

Selecteer de bridge_local, klik op "next".

Hap AC RB962UiGS-5HacT2HnT

Klik op "next" om verder te doen.

Hap AC RB962UiGS-5HacT2HnT

Als alles goed is ingesteld wordt alles automatisch ingevuld, je moet juist steeds bevestigen met "next".

Hap AC RB962UiGS-5HacT2HnT

De gateway is uw router, het IP_adres komt van de bridge die je het volgend IP-adres hebt gegeven. Klik op "next".

Hap AC RB962UiGS-5HacT2HnT

Hier zie je de IP-adressen die gaan uitgegeven worden aan de pc's loptops' Iphones en zo meer. klik op "next".

Hap AC RB962UiGS-5HacT2HnT

Als DNS-server geef je het IP-adres in van de router, klik op "next".

Hap AC RB962UiGS-5HacT2HnT

Hiermee bepaal je de lease duur, dit wil zeggen, de duur dat een IP-adress zal gereserveerd worden voor een pc of dergelijke. klik op "next".

Hap AC RB962UiGS-5HacT2HnT

Ziezo, de DHCP-server voor de interface "bridge_local" is ingesteld, herhaal deze procedure voor een andere ethernet poort indien je meerdere ip-pools gebruikt.

Hap AC RB962UiGS-5HacT2HnT

Nu ga ik tonen hoe je de DNS moet instellen. Klik in het hoofdmenu op "IP" vervolgens op "DNS".

Hap AC RB962UiGS-5HacT2HnT

Bij DNS-servers kies ik er van Google.

Hap AC RB962UiGS-5HacT2HnT

Klik op "static".

Hap AC RB962UiGS-5HacT2HnT

Klik op het blauwe kruisje en vul bij "name" "router.home" in. Bij "IP-address" vul het IP-adres van uw router in 192.168.100.1 in mijn geval.
Klik op "ok".

Hap AC RB962UiGS-5HacT2HnT

Als je "allow remote requests" aanvinkt wordt de DNS-client een DNS-server, die kunnen de mensen van buiten uw netwerk misbruiken. Door een firewall rule in te stellen blokken we de externe DNS aanvragen terwijl je die voor uw interne netwerk goed kan gebruiken.

Klik op "new terminal" in het hoofd venster.

Block inkomende DNS-aanvragen
  • /ip firewall filter
  • add action=drop chain=input dst-port=53 in-interface=ether1_isp1 protocol=udp
  • add action=drop chain=input dst-port=53 in-interface=ether2_isp2 protocol=udp

Kopieer het bovenstaande sript en plak het vervolgens in het "new terminal" venster. Klaar! Nu de DNS-server is afgeschermd kan er geen misbruik meer worden gemaakt van buiten af.

Failover configuratie.

Hap AC RB962UiGS-5HacT2HnT

Open "new terminal" in het hoofd menu.

Tool netwatch script.
  • /tool netwatch
  • add comment=CheckCon down-script="/ip route set [find comment=\"\
  • isp1\"] distance=20\r\
  • \n/ip route set [find comment=\"isp22\"] disabled=no\r\
  • \n/tool e-mail send to=\"YourEmailAddress\" body=\
  • \"Connection with isp1 Lost, Switched to isp2\" \
  • subject=\
  • \"Lost connection with isp1\"\r\
  • \n/ ip firewall connection remove [find dst-address=\"\
  • 192.168.25.1\"]" host=81.83.28.206 interval=5s timeout=2s \
  • up-script="/ip route set [find comment=\"isp1\"] distance=1\r\
  • \n/ip route set [find comment=\"isp2\"] disabled=no\r\
  • \n/tool e-mail send to=\"YourEmailAddress\" body=\
  • \"Connection with isp1 Regained, Switched back to is\
  • p1\" subject=\"Regained connection with isp1\"\r\
  • \n/ip firewall connection remove [find dst-address=\"\
  • 192.168.25.1\"]"

Hap AC RB962UiGS-5HacT2HnT

Kopieer en plak het bovenstaand script in een editor, pas de IP-adressen, email en comentaren aan. Host= de DNS-server die je wil gaan pingen. De 192.168.25.1 = de standaard gateway van ISP1 (de router van isp1). Vergeet niet bij "tools" "email" uw email gegevens in te vullen.

Hap AC RB962UiGS-5HacT2HnT

Om te voorkomen dat de pings via isp2 gaan moet deze pings geblokkeerd worden. Klik in het hoofdmenu op "ip" "firewall"

Hap AC RB962UiGS-5HacT2HnT

Bij "filter rules klik je op het blauwe kruisje.

Hap AC RB962UiGS-5HacT2HnT

Bij het onderkopje "general" selecteer "chain" "output" "Dst-address kies je het IP-adres waartoe je gaat pingen. "Out interface" selecteer je "ether2_isp2".

Hap AC RB962UiGS-5HacT2HnT

Klik verder naar "action" en selecteer "drop". De pings worden daardoor nu geblokkeerd. Klik op "ok". De failover is in orde als je alles goed hebt uitgevoerd. Het bijzonderste is dat je de IP-adressen moet veranderen en aanpassen naargelang uw situatie. We kunnen hier nog de wireless settings bespreken maar dan gaat de pagina toch wat te lang worden.

Top