failover naar 3g proximus

Telenet naar 3G Proximus failover script

failover naar 3g proximus

telenet failover naar 3G proximus script
Het is aangeraden om als bedrijf of school een redundant netwerk op te bouwen.
Je hebt dan uiteraard twee ISP modems nodig en het liefst dan nog van twee verschillende internet aanbieders.

Waarom twee verschillende internet aanbieders?

Als internet aanbieder A een defect heeft op zijn netwerk kan internet aanbieder B wel internet leveren.
 Zodoende bouw je de beste en bedrijfszekerste redundantie op.
Ik illustreer dit nu wel met een Vodafone USB-stick maar voor bedrijven kan dat natuurlijk zoals ik al aanhaalde met twee verschillende modems en internet aanbieders. Een 3 en 4G verbinding zou trouwens voor grote afnemers zoals bedrijven en scholen wat te kostelijk uitvallen. 

Hoe werkt deze failover configuratie?


In dit voorbeeld illustreer ik een redundante Telenet en een mobiele 3G Proximus verbinding.
Als je twee gateways hebt kan je de tweede uitschakelen tot de eerste gateway uitvalt.
 Het is de bedoeling als de eerste gateway uitvalt de tweede gateway het overneemt totdat de eerste terug is hersteld.
Dit ter illustratie want de mogelijkheden zijn legio zoals al aangehaald. 
Vervolgens is dit één van de voorbeelden hoe je redundantie op je netwerk kunt opbouwen. Want binnenkort zet ik op de blog nog een voorbeeld online. 

Hoe gaat telenet failover naar 3G Proximus script te werk?

Hoe gaat telenet failover naar 3G Proximus script te werk?

Ether1 is de WAN aansluiting waar je uw Telenet router moet op aansluiten. De gateway van Telenet is in dit voorbeeld 192.168.0.1
Aangenomen dat je de USB-stick al hebt ingeplugd en dat de lte1 interface zichtbaar is bij "interfaces".

Als controle pingt het script in netwatch naar een publieke DNS-server 8.8.8.8 via de Telenet gateway (router).
Echter indien deze geen antwoord krijgt via de Telenet gateway schakelt die automatisch over naar de 3G USB-stick van Proximus.

 Door middel van de routing distance te veranderen.
Vervolgens wordt door een firewall rule het pingen naar 8.8.8.8 via de tweede gateway (Proximus)geblokt.
 Komt Telenet terug online schakelt die terug over naar Telenet door middel van de routing distance te veranderen.

Als controle pingt het script in netwatch naar een publieke DNS-server 8.8.8.8 via de Telenet gateway (router).
Echter indien deze geen antwoord krijgt via de Telenet gateway schakelt die automatisch over naar de 3G USB-stick van Proximus.

 Door middel van de routing distance te veranderen.
Vervolgens wordt door een firewall rule het pingen naar 8.8.8.8 via de tweede gateway (Proximus)geblokt.
 Komt Telenet terug online schakelt die terug over naar Telenet door middel van de routing distance te veranderen.
telenet failover naar 3G proximus script
failover naar 3g proximus
telenet naar 3g proximus

Met deze 3G USB-stick van Vodafone doen we een failover naar 3g proximus

failover naar 3g proximus
failover naar 3g proximus

De gateway van de 3G USB-stick is 192.168.9.1. Vermits je gateways met andere IP-adressen zijn geconfigureerd moet je uiteraard daar in de configuratie rekening mee houden.
De LAN  configuratie is 192.168.100.0/24 met daarop een DHCP-server geconfigureerd.

telenet failover naar 3G proximus script
failover naar 3g proximus
telenet naar 3g proximus

Dit is het routerboard dat ik telenet failover naar 3G Proximus heb getest. Er zijn nog andere 3G of 4G dongels maar deze moet je eens uitzoeken welke compatibel zijn.

telenet failover naar 3G proximus script
failover naar 3g proximus

Routerboard

RouterOs

Bios firmware

3G USB-stick

RB951G-2GnD

6.36.4 bugfix

3.33

Vodafone K4305

De volledige code kan je hier kopiëren en plakken in een tekst editor pas de gateways aan.
Vervolgens kan je het bewerkte script in new terminal plakken.
Het beste is om een netwerkkabel te verbinden met ether5 en te verbinden met MAC-adres zoals je hier kan zien, met de bedoeling je verbinding niet kwijt te raken of je moet herbeginnen.
Dit is wat betreft failover naar 3g proximus

failover naar 3g proximus
telenet naar 3g proximus

De volledige code kan je eerst hier kopieren, plakken in een editor, aanpassen aan uw gateway IP's, opslaan in uw editor, en dan de bewerkte code terug kopieren en plakken in "new terminal".

OPGELET! Reset eerst het routerboard zonder default instellingen! en plak dan de code in "new terminal".

Reset eerst het Mikrotik Routerboard zonder default instellingen en plak dan de code in "new terminal".
telenet naar 3g proximus


/interface lte

set [ find ] mac-address=

xx:xx:xx:xx:xx:xx

 

/interface bridge

add name=bridge1

/interface wireless

set [ find default-name=wlan1 ] band=2ghz-b/g/ncountry=belgium frequency=2447 mode=ap-bridge

/interface ethernet

set [ find default-name=ether1 ] name=ether1-telenet

set [ find default-name=ether2 ] name=ether2-lan

set [ find default-name=ether3 ] master-port=ether2-lanname=ether3-lan

set [ find default-name=ether4 ] master-port=ether2-lanname=ether4-lan

set [ find default-name=ether5 ] master-port=ether2-lanname=ether5-lan

/ip pool

add name=dhcp_pool1 ranges=192.168.100.2-192.168.100.254

/ip dhcp-server

add address-pool=dhcp_pool1 disabled=no interface=bridge1lease-time=1d name=dhcp1

/interface bridge port

add bridge=bridge1 interface=ether2-lan

add bridge=bridge1 interface=wlan1

/ip address

add address=192.168.100.1/24 interface=bridge1network=192.168.100.0

/ip dhcp-client

add default-route-distance=0 dhcp-options=hostname,clientiddisabled=no interface=ether1-telenet

add default-route-distance=0 dhcp-options=hostname,clientiddisabled=no interface=lte1

/ip dhcp-server network

add address=192.168.100.0/24 gateway=192.168.100.1

/ip firewall filter

add action=drop chain=output comment="Drop pings to8.8.8.8 if they go through proximus" dst-address=8.8.8.8 out-interface=lte1

/ip firewall nat

add action=masquerade chain=srcnatout-interface=ether1-telenet

add action=masquerade chain=srcnat out-interface=lte1

/ip route

add comment=telenet distance=1 gateway=192.168.0.1 scope=11

add comment=proximus distance=10 gateway=192.168.9.1

add comment="Force test pings through telenet"distance=1 dst-address=8.8.8.8/32 gateway=192.168.0.1

/system clock

set time-zone-name=Europe/Brussels

/system leds

set 0 interface=wlan1

/tool e-mail

set from= start-tls=yes

/tool netwatch

add comment=CheckCon down-script="/ip route set [findcomment=\"telenet\"] distance=20\r\

\n/ip route set [find comment=\"proximus\"]disabled=no\r\

\n/tool e-mail send to=\"test@wirelessinfo.be\"body=\"Connection with telenet Lost, Switched to proximus\"subject=\"Lost connection with telenet\"\r\

\n/ ip firewall connection remove [finddst-address=\"192.168.0.1\"]" host=8.8.8.8 interval=5stimeout=2s up-script="/ip route set [find comment=\"telenet\"]distance=1\r\

\n/ip route set [find comment=\"proximus\"]disabled=no\r\

\n/tool e-mail send to=\"info@wirelessinfo.be\"body=\"Connection with telenet Regained, Switched back to telenet\"subject=\"Regained connection with telenet\"\r\

\n/ip firewall connection remove [finddst-address=\"192.168.0.1\"]"

/interface lte

set [ find ] mac-address=

xx:xx:xx:xx:xx:xx

 

/interface bridge

add name=bridge1

/interface wireless

set [ find default-name=wlan1 ] band=2ghz-b/g/n country=belgium frequency=2447 mode=ap-bridge

/interface ethernet

set [ find default-name=ether1 ] name=ether1-telenet

set [ find default-name=ether2 ] name=ether2-lan

set [ find default-name=ether3 ] master-port=ether2-lan name=ether3-lan

set [ find default-name=ether4 ] master-port=ether2-lan name=ether4-lan

set [ find default-name=ether5 ] master-port=ether2-lan name=ether5-lan

/ip pool

add name=dhcp_pool1 ranges=192.168.100.2-192.168.100.254

/ip dhcp-server

add address-pool=dhcp_pool1 disabled=no interface=bridge1 lease-time=1d name=dhcp1

/interface bridge port

add bridge=bridge1 interface=ether2-lan

add bridge=bridge1 interface=wlan1

/ip address

add address=192.168.100.1/24 interface=bridge1 network=192.168.100.0

/ip dhcp-client

add default-route-distance=0 dhcp-options=hostname,clientid disabled=no interface=ether1-telenet

add default-route-distance=0 dhcp-options=hostname,clientid disabled=no interface=lte1

/ip dhcp-server network

add address=192.168.100.0/24 gateway=192.168.100.1

/ip firewall filter

add action=drop chain=output comment="Drop pings to 8.8.8.8 if they go through proximus" dst-address=8.8.8.8 out-interface=lte1

/ip firewall nat

add action=masquerade chain=srcnat out-interface=ether1-telenet

add action=masquerade chain=srcnat out-interface=lte1

/ip route

add comment=telenet distance=1 gateway=192.168.0.1 scope=11

add comment=proximus distance=10 gateway=192.168.9.1

add comment="Force test pings through telenet" distance=1 dst-address=8.8.8.8/32 gateway=192.168.0.1

/system clock

set time-zone-name=Europe/Brussels

/system leds

set 0 interface=wlan1

/tool e-mail

set from= start-tls=yes

/tool netwatch

add comment=CheckCon down-script="/ip route set [find comment=\"telenet\"] distance=20\r\

\n/ip route set [find comment=\"proximus\"] disabled=no\r\

\n/tool e-mail send to=\"test@wirelessinfo.be\" body=\"Connection with telenet Lost, Switched to proximus\" subject=\"Lost connection with telenet\"\r\

\n/ ip firewall connection remove [find dst-address=\"192.168.0.1\"]" host=8.8.8.8 interval=5s timeout=2s up-script="/ip route set [find comment=\"telenet\"] distance=1\r\

\n/ip route set [find comment=\"proximus\"] disabled=no\r\

\n/tool e-mail send to=\"info@wirelessinfo.be\" body=\"Connection with telenet Regained, Switched back to telenet\" subject=\"Regained connection with telenet\"\r\

\n/ip firewall connection remove [find dst-address=\"192.168.0.1\"]"

De gateway van de 3G USB-stick is 192.168.9.1. Als je gateways met andere IP-adressen zijn geconfigureerd moet je daar in de configuratie rekening mee houden.

De LAN in deze configuratie is 192.168.100.0/24 met daarop een DHCP-server geconfigureerd.

Als controle pingt het script in netwatch naar een publieke DNS-server 8.8.8.8 via de Telenet gateway. Indien deze geen antwoord krijgt via de Telenet gateway schakelt die automatisch over naar de 3G USB-stick van Proximus, door de routing distance te veranderen. Op dit ogenblik wordt door een firewall rule het pingen naar 8.8.8.8 via de tweede gateway (Proximus)geblokt. Komt Telenet terug online schakelt die terug over naar Telenet door middel van de routing distance te veranderen.

In dit voorbeeld neem ik nu een Telenet en Proximus gateway, maar je kan dit doen met andere interfaces. Als je twee gateways hebt of nog een voorbeeld twee draadloze uplinken als redundantie kan je die ene uitschakelen tot de eerste draadloze link uitvalt. Dit om maar iets te vernoemen want de mogelijkheden zijn legio.

Ether1 is de WAN aansluiting waar je uw Telenet router moet op aansluiten. De gateway van Telenet is in dit voorbeeld 192.168.0.1

Ik ga er vanuit dat je de USB-stick al hebt ingeplugd en dat de lte1 interface zichtbaar is bij "interfaces".