Deel dit onderwerp alstublieft!

Mikrotik 8x WAN failover configuratie

Waar gaat dit artikel over

Mikrotik 8x WAN failover configureren

Mikrotik 8x WAN failover is één van de veelgevraagde tutorials op het forum en ook ik krijg regelmatig deze vraag. Daarom heb ik er mij op toegelegd om deze failover configuratie op video vast te leggen. Op deze manier zal de 8X WAN failover configuratie duidelijker worden voor jullie.

Denk eraan dat deze configuratie is gemaakt met vaste IP-adressen wat de WAN betreft. En ik maak gebruik van de DHCP-client op de Mikrotik router.

Veel Mikrotik tutorials zijn verouderd en heb geen enkele werkend gevonden, het heeft me ongeveer twee weken gekost om een goede configuratie te vinden.
In de 8x WAN failover met load-balancing heb ik de video tutorial gemaakt aan de hand met het kopiëren en plakken in verschillende stappen.

Na een RouterOS update boven de versie 6.37.4 kan je problemen ondervinden

Ondanks ik in deze tutorial één LAN demonstreer kan je door middel van een firewall address-list nog andere IP-range's gaan toevoegen.
Jij moet er wel op toezien dat de IP-range van je ISP-modems of routers overeenkomen met deze tutorial.

Ik heb al een load-balancing tutorial aangemaakt maar deze werkte niet na de RouterOS v 6.37.4. Doch na lang zoeken en proberen ben ik erin geslaagd om een werkende failover aan te maken.

Configuratie uitgevoerd met een RB3011UiAS-RM

RouterOS versie 6.44
Firmware 6.44

Ik heb ook een 4x WAN failover tutorial aangemaakt waar ik alles stap voor stap configureer

Onder deze eerste tutorial heb ik ook een 4xWAN configuratie aangemaakt. En dit met een stap voor stap configuratie en hier krijg je ook de code die je kan gebruiken om de configuratie tot een goed eind te brengen. Doch je kan de volledige configuratie zelf aanmaken door middel van de video tutorial.

Mikrotik 8x WAN failover configuratie

Welke functie heeft de 8X WAN failover configuratie op je Mikrotik router

Met de failover configuratie verkrijg je een redundant netwerk, maar je kan door middel van de Mikrotik 8x WAN failover de bandbreedte vermeerderen.
Deze tutorial is wel meer naar bedrijven gericht. Dit omdat je zoals hier in dit voorbeeld 8 ISP routers of modems moet hebben.
De kosten lopen dan vlug op wat voor een particulier iemand niet haalbaar is. 

Met deze failover configuratie kan je de volledige bandbreedte van alle acht de ISP modems of routers gebruiken alsof je maar één internet uplink hebt.
Dit met het verschil dat je een grotere bandbreedte creëert  en als er een ISP modem uitvalt de andere zeven modems of routers de taak verder zet.

Voordeel van de 8x WAN failover configuratie

Je hebt dus als voordeel dat je zowel redundantie als een grotere bandbreedte hebt op je netwerk. Door de bandbreedte per ISP modem te bundelen.
Als particulier kan je een failover configuratie aanmaken met 2 ISP modems of routers. Of je kan een failover netwerk configureren zoals hier te zien is met een 4G verbinding.

Indien je een internet verbinding hebt met een te lage bandbreedte is deze 8x WAN failover configuratie de ideale oplossing. Waarom?
Omdat je meerdere internetverbindingen op een zodanige manier gebruikt, dat het internetverkeer evenredig verdeeld wordt over alle WAN verbindingen.

Wat zijn de nadelen van de 8x WAN failover configuratie

Ik kan maar één nadeel bedenken en dat is de kostprijs van de 8 ISP abonnementen dat je nodig hebt. Doch indien je zoveel bandbreedte nodig hebt om bijvoorbeeld een grote camping, jachthaven, hotel, school of bedrijf van internet te voorzien. Kan je daar zeker en vast profijt uithalen.

Welke failover techniek ga ik hier gebruiken en wat heeft PCC hiermee te maken?

PCC staat voor Per Connection Classifier en verdeelt de inkomende data gegevens in stromen. Vervolgens gebruikt PCC routeringsregels om het verkeer gelijkmatig over meerdere WAN verbindingen te sorteren. 

Deze 8x WAN failover maakt gebruik van een hash-algoritme om het verkeer eerst te sorteren op basis van het bronadres, bronpoort, bestemmingsadres, bestemmingspoort of een combinaties daarvan. Gebruik van pakketmarkering en routemarkeringen en verschillende routeringstabellen om te zorgen dat het verkeer volgt op een opgegeven route uit de gespecificeerde WAN-interface. Dit gebeurd door middel van de Mangle rules die ik hier ga instellen op deze video tutorial.

Het data verkeer dat door WAN2 wordt doorgestuurd zal terug via WAN2 worden ontvangen. Anders zouden de data pakketten verloren gaan. 

PCC en modulaire rekenkunde

De Per Connection Classifier of anders gezegd PCC instelling moet worden aangepast en er moet rekening worden gehouden met een paar zaken.
PCC neemt geselecteerde velden van de IP-header en zet met behulp van een hash-algoritme geselecteerde velden om in 32-bits waarde.

Deze waarde wordt dan gedeeld door een noemer en de rest wordt dan vergeleken met een opgegeven rest.
De modulaire rekenkunde wordt vertegenwoordigd door een % teken en het wordt uitgesproken als "mod".
Om te werken met modulaire wiskunde, voor PCC moet je dit als volgt zien. Even redeneren hoe per connection classifier moet worden ingesteld.


Zie dit als hoeveel is er nog over (rest) nadat je de tweede waarde namelijk de noemer hebt afgetrokken van de eerste waarde (teller).
Hoeveel keer kan je de noemer gaan aftrekken van de teller zonder dat die negatief wordt. 

Enkele voorbeelden van modulaire wiskunde


  Teller = 3 noemer = 3
  3% 3 = 0 omdat 3 - 3 = 0 is
  4% 3 = 1 omdat 4 - 3 = 1 is 
  5% 3 = 2 omdat 5 - 3 = 2 is 
  6% 3 = 0, omdat 6 - 3 = 3, trek 3 opnieuw af = 0 overgebleven


Indien er iemand weet hoe dit precies in zijn werk gaat mag je me zeker inlichten door een mail te zenden. Ik kreeg namelijk een mail met een probleem dat de failover werkt maar de bandbreedte vermeerderd niet per WAN. In de onderstaande video zoek ik naar een oplossing, als het na de wijzigingen werkt, mail me even wat de oplossing was. Ik reken op jullie hulp. 

Na lang zoeken en experimenteren heb ik de 8x WAN failover met load-balancing werkend gekregen

Door middel van deze video tutorial en daarbij ook nog de stap voor stap code die je in het new terminal venster kunt gaan plakken hoop ik dat deze 8x WAN failover een grote hulp zal zijn voor jou. Na een paar Mikrotik tutorials te hebben uitgeprobeerd wilde het toch niet lukken de configuratie werkend te krijgen.

Doch mijn grote moeite heeft toch goede vruchten afgeworpen. Hieronder de werkende Mikrotik failover en koad-balancing configuratie.

8X WAN failover configuratie kan je hier op je Mikrotik router configureren in 7 stappen

Voor de ongeduldige mensen die vlug resultaat willen zien. Ik heb hieronder de code voorzien van de 8x failover. Kopieer en plak stap1 tot en met stap7 in het new terminal venster van je Mikrotik router. Voor de Mikrotik configuraties gebruik je het beste Winbox die speciaal door Mikrotik is ontworpen om Mikrotik routers te configureren.

Al mijn tutorials zijn zo precies en volledig mogelijk aangemaakt. Doch mocht er een fout ingeslopen zijn laat het me weten als je wil. De code hieronder is alvast werkend bevonden. Ik wens je alvast veel succes en configuratie plezier toe.

Opgelet! Je zal de IP-adressen van je WAN modems of routers moeten aanpassen, oftewel zal je de configuratie moeten gaan wijzigen door de WAN IP-adressen te gaan wijzigen. Ik raad je aan om de IP-adressen van de WAN routers of modems aan te passen.  

Stap1: Verander de ethernet interfaces van naam

/interface ethernet
set [ find default-name=ether9 ] name=LAN
set [ find default-name=ether1 ] name=WAN1
set [ find default-name=ether2 ] name=WAN2
set [ find default-name=ether3 ] name=WAN3
set [ find default-name=ether4 ] name=WAN4
set [ find default-name=ether5 ] name=WAN5
set [ find default-name=ether6 ] name=WAN6
set [ find default-name=ether7 ] name=WAN7
set [ find default-name=ether8 ] name=WAN8

Stap2: Geef de interfaces een IP-adres

/ip address
add address=192.168.100.1/24 interface=LAN network=192.168.100.0
add address=192.168.101.2/24 interface=WAN1 network=192.168.101.0
add address=192.168.102.2/24 interface=WAN2 network=192.168.102.0
add address=192.168.103.2/24 interface=WAN3 network=192.168.103.0
add address=192.168.104.2/24 interface=WAN4 network=192.168.104.0
add address=192.168.105.2/24 interface=WAN5 network=192.168.105.0
add address=192.168.106.2/24 interface=WAN6 network=192.168.106.0
add address=192.168.107.2/24 interface=WAN7 network=192.168.107.0
add address=192.168.108.2/24 interface=WAN8 network=192.168.108.0

Stap3: Voeg de DNS-servers toe

/ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4

Stap4: Het configureren van de DHCP-server

/ip pool
add name=dhcp_pool0 ranges=192.168.100.20-192.168.100.254
/ip dhcp-server
add address-pool=dhcp_pool0 disabled=no interface=LAN1 name=dhcp1
/ip dhcp-server network
add address=192.168.100.0/24 gateway=192.168.100.1

Stap5: Maak de mangle rules aan

/ip firewall mangle
add action=mark-connection chain=input in-interface=WAN1 new-connection-mark=WAN1_conn
add action=mark-connection chain=input in-interface=WAN2 new-connection-mark=WAN2_conn
add action=mark-connection chain=input in-interface=WAN3 new-connection-mark=WAN3_conn
add action=mark-connection chain=input in-interface=WAN4 new-connection-mark=WAN4_conn
add action=mark-connection chain=input in-interface=WAN5 new-connection-mark=WAN5_conn
add action=mark-connection chain=input in-interface=WAN6 new-connection-mark=WAN6_conn
add action=mark-connection chain=input in-interface=WAN7 new-connection-mark=WAN7_conn
add action=mark-connection chain=input in-interface=WAN8 new-connection-mark=WAN8_conn
add action=mark-routing chain=output connection-mark=WAN1_conn new-routing-mark=to_WAN1
add action=mark-routing chain=output connection-mark=WAN2_conn new-routing-mark=to_WAN2
add action=mark-routing chain=output connection-mark=WAN3_conn new-routing-mark=to_WAN3
add action=mark-routing chain=output connection-mark=WAN4_conn new-routing-mark=to_WAN4
add action=mark-routing chain=output connection-mark=WAN5_conn new-routing-mark=to_WAN5
add action=mark-routing chain=output connection-mark=WAN6_conn new-routing-mark=to_WAN6
add action=mark-routing chain=output connection-mark=WAN7_conn new-routing-mark=to_WAN7
add action=mark-routing chain=output connection-mark=WAN8_conn new-routing-mark=to_WAN8
add action=accept chain=prerouting dst-address=192.168.101.0/24 in-interface=LAN
add action=accept chain=prerouting dst-address=192.168.102.0/24 in-interface=LAN
add action=accept chain=prerouting dst-address=192.168.103.0/24 in-interface=LAN
add action=accept chain=prerouting dst-address=192.168.104.0/24 in-interface=LAN
add action=accept chain=prerouting dst-address=192.168.105.0/24 in-interface=LAN
add action=accept chain=prerouting dst-address=192.168.106.0/24 in-interface=LAN
add action=accept chain=prerouting dst-address=192.168.107.0/24 in-interface=LAN
add action=accept chain=prerouting dst-address=192.168.108.0/24 in-interface=LAN
add action=mark-connection chain=prerouting dst-address-type=!local in-interface=LAN new-connection-mark=WAN1_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:8/0
add action=mark-connection chain=prerouting dst-address-type=!local in-interface=LAN new-connection-mark=WAN2_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:8/1
add action=mark-connection chain=prerouting dst-address-type=!local in-interface=LAN new-connection-mark=WAN3_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:8/2
add action=mark-connection chain=prerouting dst-address-type=!local in-interface=LAN new-connection-mark=WAN4_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:8/3
add action=mark-connection chain=prerouting dst-address-type=!local in-interface=LAN new-connection-mark=WAN4_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:8/4
add action=mark-connection chain=prerouting dst-address-type=!local in-interface=LAN new-connection-mark=WAN4_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:8/5
add action=mark-connection chain=prerouting dst-address-type=!local in-interface=LAN new-connection-mark=WAN4_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:8/6
add action=mark-connection chain=prerouting dst-address-type=!local in-interface=LAN new-connection-mark=WAN4_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:8/7
add action=mark-routing chain=prerouting connection-mark=WAN1_conn in-interface=LAN new-routing-mark=to_WAN1
add action=mark-routing chain=prerouting connection-mark=WAN2_conn in-interface=LAN new-routing-mark=to_WAN2
add action=mark-routing chain=prerouting connection-mark=WAN3_conn in-interface=LAN new-routing-mark=to_WAN3
add action=mark-routing chain=prerouting connection-mark=WAN4_conn in-interface=LAN new-routing-mark=to_WAN4
add action=mark-routing chain=prerouting connection-mark=WAN5_conn in-interface=LAN new-routing-mark=to_WAN5
add action=mark-routing chain=prerouting connection-mark=WAN6_conn in-interface=LAN new-routing-mark=to_WAN6
add action=mark-routing chain=prerouting connection-mark=WAN7_conn in-interface=LAN new-routing-mark=to_WAN7
add action=mark-routing chain=prerouting connection-mark=WAN8_conn in-interface=LAN new-routing-mark=to_WAN8

Stap6: Configureer de NAT-rules

/ip firewall nat
add action=masquerade chain=srcnat out-interface=WAN1
add action=masquerade chain=srcnat out-interface=WAN2
add action=masquerade chain=srcnat out-interface=WAN3
add action=masquerade chain=srcnat out-interface=WAN4
add action=masquerade chain=srcnat out-interface=WAN5
add action=masquerade chain=srcnat out-interface=WAN6
add action=masquerade chain=srcnat out-interface=WAN7
add action=masquerade chain=srcnat out-interface=WAN8

Stap7: Voeg de default routes toe

/ip route
add check-gateway=ping distance=1 gateway=192.168.101.1 routing-mark=to_WAN1
add check-gateway=ping distance=1 gateway=192.168.102.1 routing-mark=to_WAN2
add check-gateway=ping distance=1 gateway=192.168.103.1 routing-mark=to_WAN3
add check-gateway=ping distance=1 gateway=192.168.104.1 routing-mark=to_WAN4
add check-gateway=ping distance=1 gateway=192.168.105.1 routing-mark=to_WAN5
add check-gateway=ping distance=1 gateway=192.168.106.1 routing-mark=to_WAN6
add check-gateway=ping distance=1 gateway=192.168.107.1 routing-mark=to_WAN7
add check-gateway=ping distance=1 gateway=192.168.108.1 routing-mark=to_WAN8
add check-gateway=ping distance=1 gateway=192.168.101.1
add check-gateway=ping distance=2 gateway=192.168.102.1
add check-gateway=ping distance=3 gateway=192.168.103.1
add check-gateway=ping distance=4 gateway=192.168.104.1
add check-gateway=ping distance=5 gateway=192.168.105.1
add check-gateway=ping distance=6 gateway=192.168.106.1
add check-gateway=ping distance=7 gateway=192.168.107.1
add check-gateway=ping distance=8 gateway=192.168.108.1

4X WAN failover configuratie kan je hier op je Mikrotik router configureren

Deze 4x failover configuratie is uitgevoerd op een hEX RB750Gr3 met RouterOS 6.44 . Je doet stap voor stap de 4x failover configuratie door de code in het new terminal venster te plakken. Eventuele aanpassingen van WAN IP-adressen zijn noodzakelijk en afhankelijk van je ISP-routers IP-range. De 4x failover met load balancing configuratie ga ik hier in deze video tutorial volledig uitvoeren.

mikrotik 4x failover and load-balancing

Stap1: Verander de ethernet interfaces van naam

/interface ethernet
set [ find default-name=ether5 ] name=LAN
set [ find default-name=ether1 ] name=WAN1
set [ find default-name=ether2 ] name=WAN2
set [ find default-name=ether3 ] name=WAN3
set [ find default-name=ether4 ] name=WAN4

Stap2: Geef de interfaces een IP-adres

/ip address
add address=192.168.100.1/24 interface=LAN network=192.168.100.0
add address=192.168.101.2/24 interface=WAN1 network=192.168.101.0
add address=192.168.102.2/24 interface=WAN2 network=192.168.102.0
add address=192.168.103.2/24 interface=WAN3 network=192.168.103.0
add address=192.168.104.2/24 interface=WAN4 network=192.168.104.0

Stap3: Voeg de DNS-servers toe

/ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4

Stap4: Het configureren van de DHCP-server

/ip pool
add name=dhcp_pool0 ranges=192.168.100.20-192.168.100.254
/ip dhcp-server
add address-pool=dhcp_pool0 disabled=no interface=LAN1 name=dhcp1
/ip dhcp-server network
add address=192.168.100.0/24 gateway=192.168.100.1

Stap5: Maak de mangle rules aan

/ip firewall mangle
add action=mark-connection chain=input in-interface=WAN1 new-connection-mark=WAN1_conn
add action=mark-connection chain=input in-interface=WAN2 new-connection-mark=WAN2_conn
add action=mark-connection chain=input in-interface=WAN3 new-connection-mark=WAN3_conn
add action=mark-connection chain=input in-interface=WAN4 new-connection-mark=WAN4_conn
add action=mark-routing chain=output connection-mark=WAN1_conn new-routing-mark=to_WAN1
add action=mark-routing chain=output connection-mark=WAN2_conn new-routing-mark=to_WAN2
add action=mark-routing chain=output connection-mark=WAN3_conn new-routing-mark=to_WAN3
add action=mark-routing chain=output connection-mark=WAN4_conn new-routing-mark=to_WAN4
add action=accept chain=prerouting dst-address=192.168.101.0/24 in-interface=LAN
add action=accept chain=prerouting dst-address=192.168.102.0/24 in-interface=LAN
add action=accept chain=prerouting dst-address=192.168.103.0/24 in-interface=LAN
add action=accept chain=prerouting dst-address=192.168.104.0/24 in-interface=LAN
add action=mark-connection chain=prerouting dst-address-type=!local in-interface=LAN new-connection-mark=WAN1_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:4/0
add action=mark-connection chain=prerouting dst-address-type=!local in-interface=LAN new-connection-mark=WAN2_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:4/1
add action=mark-connection chain=prerouting dst-address-type=!local in-interface=LAN new-connection-mark=WAN3_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:4/2
add action=mark-connection chain=prerouting dst-address-type=!local in-interface=LAN new-connection-mark=WAN4_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:4/3
add action=mark-routing chain=prerouting connection-mark=WAN1_conn in-interface=LAN new-routing-mark=to_WAN1
add action=mark-routing chain=prerouting connection-mark=WAN2_conn in-interface=LAN new-routing-mark=to_WAN2
add action=mark-routing chain=prerouting connection-mark=WAN3_conn in-interface=LAN new-routing-mark=to_WAN3
add action=mark-routing chain=prerouting connection-mark=WAN4_conn in-interface=LAN new-routing-mark=to_WAN4

Stap6: Configureer de NAT-rules

/ip firewall nat
add action=masquerade chain=srcnat out-interface=WAN1
add action=masquerade chain=srcnat out-interface=WAN2
add action=masquerade chain=srcnat out-interface=WAN3
add action=masquerade chain=srcnat out-interface=WAN4

Stap7: Voeg de default routes toe

/ip route
add check-gateway=ping distance=1 gateway=192.168.101.1 routing-mark=to_WAN1
add check-gateway=ping distance=1 gateway=192.168.102.1 routing-mark=to_WAN2
add check-gateway=ping distance=1 gateway=192.168.103.1 routing-mark=to_WAN3
add check-gateway=ping distance=1 gateway=192.168.104.1 routing-mark=to_WAN4
add check-gateway=ping distance=1 gateway=192.168.101.1
add check-gateway=ping distance=2 gateway=192.168.102.1
add check-gateway=ping distance=3 gateway=192.168.103.1
add check-gateway=ping distance=4 gateway=192.168.104.1

Steun WirelessInfo.be

Bied me een kop koffie aan of het mag iets meer zijn, zo kan ik mijn website online houden.