Deel dit onderwerp alstublieft!

Mikrotik tool email

Mikrotik tool email

De Mikrotik tool email configuratie is zeer eenvoudig uit te voeren. Toch zijn er providers die automatisch e-mailen niet toestaan. Dit komt omdat er teveel misbruik werd gemaakt om spam en dergelijke meer te verzenden. Ik heb wat providers uitgeprobeerd die het automatisch mailen toestaan. Dit wil zeggen dat de Mikrotik tool email terug gebruikt kan worden. Welke providers heb ik uitgeprobeerd: Telenet, One.com, en Gmail en allemaal met succes. Doch Gmail geeft een probleem die ik in het filmpje oplos. De betere veiligheidsinstellingen bij Gmail moet je gaan uitschakelen. Een andere oplossing is er niet als je Gmail gebruikt. Wil je Mikrotik email gebruiken en configureren bekijk zeker de onderstaande video die ik heb gemaakt. Deze zal je op weg helpen om de email configuratie om de Mikrotik router te voltooien.

Hoe kan je de Mikrotik tool email werkend krijgen op de Mikrotik router

Op deze blogpost laat ik je stap voor stap zien hoe je te werk moet gaan om de Mikrotik mail instellingen correct te configureren. Een tijd geleden kon je dit uitsluitend met Gmail. Doch tegenwoordig zijn er meer providers die dit terug toelaten. Er is wel één voorwaarde aan verbonden. Je moet je kunnen authentiseren wat wil zeggen dat je een gebruikersnaam (meestal het email adres) en een paswoord moet ingeven. Gebruik niet de onveilige POP instellingen met poort 25 of 110 want de e-mails worden niet versleutelt door het internet verzonden. De dag van vandaag is dit zeker niet verstandig om dit zomaar te laten gebeuren. Iedere kwaadwillige kan je email login en boodschap onderscheppen. Ook deze van de Mikrotik tool email bij gebruik van de onbeveiligde protocollen. 

Mikrotik tool email
tool email settings

Mikrotik tool email gebruik je het beste met een eigen email

Wat wil ik hiermee zeggen. Indien je gebruik maakt van de Mikrotik tool email gebruik geen email die je al gebruikt voor je privé berichten. Maak daarvoor een nieuwe email aan. Hierdoor wordt je privé email beschermt en blijft deze voor anderen verborgen. Indien je de Mikrotik email configuratie uitvoert gebruik bij voorkeur host namen in plaats van een IP-adres. Dit omdat één host naam meerdere servers kan hebben. Dit draagt ertoe bij dat je een redundante email-server gebruikt. 

Telenet email kan ook worden gebruikt bij de Mikrotik tool email

Wat vroeger niet het geval was wordt nu mogelijk gemaakt. Telenet email kan ook gebruikt worden om e-mails te laten zenden door de Mikrotik router. Dit heb ik persoonlijk uitgetest. Maar of alle providers dit toestaan is me niet duidelijk. Ik test deze  Mikrotik email toepassing bij mijn eigen providers. Dit maakt het wat moeilijk om te weten of andere providers dit ook ondersteunen. Je hulp is meer dan welkom, laat me weten welke provider je hebt en de email instellingen dat je gebruikt. Op deze manier kan ik deze blogpost vollediger maken.

Mikrotik email instellingen voor verschillende providers

In de hoop nog duidelijker te zijn heb ik hieronder een paar email configuraties geplaatst voor de Mikrotik router. Doch indien je een andere provider hebt mag je me steeds melden dat het is gelukt of niet. De gegevens dat je nodig hebt is de server voor uitgaande berichten. De poort en niet te vergeten Start TLS. Je kan me steeds e-mailen via het contact formulier.

One.com

Telenet.be

Proximus.be

Mikrotik tool email

Gmail.com

Bekijk de onderstaande video die ik heb gemaakt om de Mikrotik tool email instellingen te maken

Een paar bruikbare email scripts die je kan gebruiken zet ik hier online.

Indien je gebruik maakt van Mikrotik tool email kan je dit voor vele toepassingen gebruiken. Ik plaats een aantal van deze email toepassingen hier op deze blogpost. Opgelet want je zal bepaalde parameters moeten aanpassen aan de configuratie van je Mikrotik router. Ik denk dan in de eerste plaats aan de benamingen van de interfaces. En uiteraard ook op de email die in het script zit verwerkt. Let dus goed op zodat je geen fouten maakt. Anders werkt de Mikrotik tool email niet. 

Mail elke dag een backup en export door van de configuratie van je Mikrotik router

Door middel van scheduler kan je automatisch dagelijks een backup en export maken van de configuratie van je router. Daarna kan je deze doormailen zodat je steeds over een backup van je router beschikt. Ik spreek hier nu wel van dagelijks maar dit kan uiteraard aangepast worden naar wekelijks, maandelijks ik noem hier maar wat. Met dit script neem ik de twee samen. Zowel de backup als de export en zend deze door via Mikrotik tool email. Bekijk deze video hier.

:log info "backup start nu"
:global backupfile [/system identity get name]
/system backup save name=$backupfile
:delay 10s
/export file=$backupfile
:delay 10s
:log info "backup is verzonden"
/tool e-mail send to="uwemail@gmail.com" subject=("Mikrotik Backup of " . [/system identity get name]) file=($backupfile . ".backup")
:delay 10s
/tool e-mail send to="uwemail@gmail.com" subject=("Mikrotik Export of " . [/system identity get name]) file=($backupfile . ".rsc")
:log info "backup finished"

Email indien de ping tijden te hoog worden op een Point to Point link

Een zeer goed voorbeeld is dit onderstaand script. Ik heb deze gewijzigd en getest en alles werkt naar behoren. Dit script pingt naar een door jou in te geven IP-adres
Als de ping latentie te hoog wordt krijg je daar een email van. Dit is een zeer bruikbaar script bij een Point to Point verbinding. Je kan dit script ook gaan draaien op een Mikrotik SXT. Een configuratie van een Point to Point verbinding kan je hier bekijkenDit script moet worden gebruikt met scheduler.  

:local Themes "Ping latency is te hoog"
#Zet het te monitoren IP address hier onder.
:local addre 1.1.1.1;
#Zet de maximale vertraging hier onder in milliseconden.
:local ms 100;
:local avgRtt;
/tool flood-ping $addre count=10 do={
:if ($sent = 10) do={
:set avgRtt $"avg-rtt"
}}
:if ($avgRtt >= $ms) do={
#send mail
/tool e-mail send to="uwmail@gmail.com" subject=$Themes body=("MonitoringIP:$addre\ndelay:$avgRtt ms")
:log err "Message has been sent";
}

Mail indien de temperatuur van de router en CPU te hoog wordt (board en CPU temperatuur).

Dit Mikrotik email script is persoonlijk door mij bewerkt. Het vraagt de temperatuur op van zowel de router als de CPU. Als de temperatuur te hoog wordt zend deze een email. De temperatuur kan je zelf gaan bepalen. Dit script moet worden gebruikt met scheduler. Bekijk deze video hier.

:log info ("$[/system health get temperature] $[/system health get cpu-temperature]")
:if ([/system health get temperature]>20) do={/tool e-mail send to="uwemail@gmail.com" subject=[/system identity get name] body=("High temperature. Current temperature is: ".[/system health get temperature])} 
:if ([/system health get cpu-temperature]>40) do={/tool e-mail send to="uwemail@gmail.com" subject=[/system identity get name] body=("High temperature. Current cpu-temperature is: ".[/system health get cpu-temperature])}

Mail indien de temperatuur van de router te hoog wordt (board alleen).

Dit Mikrotik email script is persoonlijk door mij bewerkt. Het vraagt de temperatuur op van de router. Als de temperatuur te hoog wordt zend deze een email. De temperatuur kan je zelf gaan bepalen. Dit script moet worden gebruikt met scheduler. Indien je router alleen over een temperatuurmeter voor het board heeft kan je dit email script gaan gebruiken. Bekijk de video hier gedenk dat ik in deze video het script gebruik dat zowel de temperatuur van de router als van de CPU meet.

:log info ("$[/system health get temperature]")
:if ([/system health get temperature]>10) do={/tool e-mail send to="uwemail@gmail.com" subject=[/system identity get name] body=("High temperature. Current temperature is: ".[/system health get temperature])} 

Mail indien de voltage van de router te laag is

Indien je een router hebt die gevoed wordt met netspanning heb je normaal gezien een constante spanning. Neem als voorbeeld 27.6 volt. Doch de voeding heeft ook een batterij back-up zoals sommige Meanwell voedingen. Indien de netspanning uitvalt heeft de router geen 27.6 volt spanning maar valt terug op 24 volt. Dit omdat als back-up een 24 volt batterij wordt gebruikt. Met dit script kan je email krijgen indien de spanning is gedaald naar 24 volt bijvoorbeeld. Op deze manier wordt je tijdig verwittigd indien de netspanning is weggevallen. Zeer belangrijk de waarde van 24 volt op de Mikrotik router is 240 voor 27.6 volt is dat 276. Dit script moet worden gebruikt met scheduler.  

:log info ("$[/system health get voltage]")
:if ([/system health get voltage]<300) do={/tool e-mail send to="uwemail@gmail.com" subject=[/system identity get name] body=("Low Voltage Alarm. Current voltage is: ".[/system health get voltage])}

 E-mail elke dag de logfile door van je router naar je email adres

Indien je elke dag een logfile krijgt doorgestuurd door de Mikrotik router is dit een extra punt van controle. Het bespaard je de moeite om steeds in te loggen op je Mikrotik router. Ik richt me hier uiteraard naar de particuliere gebruiker want er zijn nog andere middelen om de logfile te bekijken. Deze mag toch niet ontbreken in deze Mikrotik tool email blogpost. Om de logfile dagelijks door te zenden moet je gebruik maken van de Mikrotik scheduler.

/log print file=logs-router1
delay 10
/tool e-mail send to="uwemail@gmail.com" subject="$[/system identity get name]  logs" \
body="$[/system clock get date] log file" file=logs-router1.txt

Mail als een netwerk toestel offline gaat

Je kan een netwerk toestel gaan pingen of deze online is of niet. Indien deze offline is kan je een email laten zenden zodat je wordt verwittigd. Dit kan gebeuren door middel van Mikrotik netwatch. Deze toepassing kan uiteraard voor veel toepassingen worden gebruikt. De code die je hiervoor nodig hebt is zeer klein maar krachtig.
Bekijk de volledige configuratie op mijn YouTube kanaal.

/tool e-mail send from="uwemail@gmail.com" body="Het netwerk toestel 1 is offline" subject="Het netwerk toestel 1 is offline" to="uwemail@gmail.com" 

Steun WirelessInfo.be

Om de kosten van de hosting en plug-ins te helpen dragen. Schenk een kleine bijdrage alstublieft.

tool email settings
tool email settings
Please follow and like us:
Pin Share

Deze website maakt gebruik van cookies. Door deze site te blijven gebruiken, accepteert u het gebruik van deze cookies.