email bij hoge latentie

email bij hoge latentie

Email bij hoge latentie

email bij hoge latentie script is vervolgens een zeer groot hulpmiddel als je een computer netwerk hebt. 
 Of indien je allerhande tunnels in je netwerk hebt zitten.
Je kan bijvoorbeeld volledig je netwerk gaan controleren door op gevoelige en druk bezette netwerksegmenten de Mikrotik router de latentie te laten meten. 
Dan is het email bij hoge latentie script hier wel op zijn plaats want  je wordt namelijk gewaarschuwd.


Ter illustratie
Er word een DDOS aanval ingezet op je netwerk waardoor de netwerk data doorvoer fel begint te verminderen. Het email bij hoge latentie script zal bij de automatische controle opmerken dat de latentie fel naar omhoog gaat en gaat je waarschuwen door middel van een email.
Een andere illustratie 


Gesteld dat je een point to point wifi link hebt geplaatst.
Er komt een storm aanzetten met als gevolg dat de antenne zoveel wind opvangt dat een van de vijzen los komt te zitten.

De antenne gaat vervolgens wat gaan draaien en het signaal aan de ander zijde van de link gaat naar beneden.

Bijgevolg gaat de snelheid van de data naar beneden maar je merkt er niets van.
Weliswaar de antennekomt losser te zitten waardoor een vijs afbreekt.
De schade kan dan bij de antenne blijven maar de antenne kan ook naar beneden vallen op een auto of een glazen veranda.
Kortom misschien wat overdreven maar als er vervolgens iets gebeurd is het te laat opgemerkt.
Daar staat tegenover dat het email bij hoge latentie script een oplossing bied.
Met de bedoeling dit tegen te gaan kan je met dit script automatisch de latentietijd gaan meten door middel van de Mikrotik router.

Je kan vervolgens ieder netwerk gaan meten die in het oog moet gehouden worden of die zwaar onder druk komt te staan.

Wat betekend latentie in verband met computer netwerken

email bij hoge latentie

Latentie in computer term is vervolgens elke vorm van vertraging van data verkeer die in een computer netwerk optreed aan te geven.

Netwerkverbindingen waarin kleine vertragingen optreden worden namelijk lage latentie netwerken genoemd.
Daarentegen worden netwerkverbindingen waarin lange vertragingen optreden hoge latentie netwerken genoemd.

Hoge latentie zorgt vervolgens voor knelpunten in elk computer netwerk en verminderd zodoende de bandbreedte van de verbinding waardoor de gegevens afgeremd worden met als gevolg dat het data transport vertraagd.

Theoretisch gezien reizen de data pakketten van punt A naar B met de snelheid van het licht.
Als je echter meer wil weten over de snelheid van het licht in verband met antennes klik je hier.

  Maar door één of meerdere factoren treed er altijd en onvermijdelijk latentie op.
Een goede netwerk latentie benaderd zo dicht mogelijk het getal 0.
Of het nu over een netwerkkabel, glasvezel of draadloze link gaat netwerklatentie heb je altijd. 

Het configureren van het email bij hoge latentie script

email bij hoge latentie

1- Klik in het hoofdvenster op "system".
2- Vervolgens op "Scheduler".

email bij hoge latentie

1- Klik op het blauwe kruisje bovenaan en bij"name" geef de scheduler taak een naam, bijvoorbeeld: To match latency time.
2- Als "start date" vul een datum van vandaag in of een datum die nog moet komen.
3- Vul eveneens bij "start time" een uur in dat nog moet komen, anders start de schedule taak niet.

4- Bij interval kies hoeveel keer de controle moet plaats vinden. Bijvoorbeeld elke 1 minuut.

email bij hoge latentie

Kopieer en bewerk het script naar uw wensen.
1- plak het bewerkte script in het schedule venster.
2- Klik op "ok".

Het email bij hoge latentie script

:local Themes "Monitor IP delay to alarmthreshold"

#Zet het te monitoren IP address hier onder.

:local addre 8.8.8.8;

#Zet de maximale vertraging hier onder in milliseconden.

:local ms 100;

:local avgRtt;

/tool flood-ping $addre count=10 do={

:if ($sent = 10) do={

:set avgRtt $"avg-rtt"

}}

:if ($avgRtt >= $ms) do={

#send mail

/tool e-mail send server=195.130.132.10 port=587user=uwusernaam password=uwpaswoord to=uwemail@gmail.com=uwemail@gmail.com
 subject=$Themes body=("MonitoringIP:$addre\ndelay:$avgRtt ms") 

:log err "Message has been sent";

}

Vergeet niet! Dit script werkt alleen maar bij Gmail. Klik hier om Mikrotik email instellingen te bekijken.