Deel dit onderwerp alstublieft!

mikrotik email bij hoge latency

Mikrotik email bij hoge latency script kan een groot hulpmiddel zijn indien je een computer netwerk hebt die is uitgerust met point-to-point links. 
Ondanks je de Mikrotik point-to-point link zorgvuldig hebt opgezet, kunnen verschillende factoren ervoor zorgen dat de link verstoort wordt.


Dit resulteert dat de performance van de link ferm achteruitgaat en de data transfer gebeurd veel trager. Om dit snel op te merken is het Mikrotik email bij hoge latency script een goed hulpmiddel. En dit omdat je dan vroegtijdig wordt verwittigd door middel van dit Mikrotik script.

Ik spreek hier van een draadloze wifi link, maar ook bekabelde of zelfs glasvezel point to point situaties trekken voordeel van dit Mikrotik email bij hoge latency script
Je kan bijvoorbeeld je backbone en druk bezette netwerksegmenten laten bewaken door de latentie te gaan meten. Dit kan eenvoudig  worden afgehandeld door de Mikrotik router, en dit door middel van te pingen van punt A naar punt B en de tijd te gaan bepalen. Dus de mogelijkheden zijn veelzijdig toepasbaar.

Mikrotik email bij hoge latency

Wat betekend latency in verband met computer netwerken?

Latency in computer term is elke vorm van vertraging van data verkeer die in een computer netwerk optreed. Deze kunnen worden gezien door middel van een ping.

Netwerkverbindingen waarin kleine vertragingen optreden worden lage latency netwerken genoemd.
Daarentegen worden netwerkverbindingen waarin lange vertragingen optreden hoge latency netwerken genoemd.

Hoge latency zorgt vervolgens voor knelpunten in elk computer netwerk en verminderd de bandbreedte van de verbinding waardoor de gegevens afgeremd worden. Dit heeft uiteraard een negatief gevolg van je netwerk omdat het data transport vertraagd. Dit gaat ten koste van de stabiliteit en kwaliteit van je computer netwerk.

Theoretisch gezien reizen de data pakketten van punt A naar B met de snelheid van het licht. Maar deze snelheid wordt door vele factoren beïnvloed.
Dit kunnen bij draadloze linken de atmosfeer, bomen, regen, sneeuw en dergelijke meer zijn. Doch bij een bekabeld netwerk kunnen er ook problemen optreden. 
Als je echter meer wil weten over de snelheid van het licht in verband met antennes klik je hier.

Maar door één of meerdere factoren treed er altijd en onvermijdelijk latency op. Een goede netwerk latency benaderd zo dicht mogelijk het getal 0.

Welke factoren kunnen ervoor zorgen dat de latency op je netwerk verhoogd?

Voorbeeld 1


Er word een DDOS aanval ingezet op je netwerk door kwaadwilligen. Je netwerk wordt op dit moment fel onder vuur genomen en er treed een flinke vertraging op.
Vooraleer je dit komt te weten zijn er al veel mensen die met hun handen in hun haar zitten. En jij bijvoorbeeld als internet leverancier komt dit als laatste te weten.

Op welke manier kom je dat dan te weten? Klanten gaan telefoneren met de klacht dat het netwerk niet meer stabiel werkt. Dit is nog niet alles want je krijgt als internet leverancier veel telefoons met mensen die niet begrijpen dat zulke dingen kunnen gebeuren. Het kan ook anders. Hoe dat zo? jij bent de eerste die het opmerkt.

Door het Mikrotik email bij hoge latency script zal direct worden opgemerkt dat de latency fel omhoog gaat en ga je direct worden gewaarschuwd door middel van een email. De Mikrotik router controleert op regelmatige basis de latency van je netwerk door middel van het Mikrotik script. Dan ben jij er zeer vlug bij en kan je direct ingrijpen.

Mikrotik email bij hoge latency

Voorbeeld 2

Gesteld dat je zorgvuldig een point to point wifi link hebt geplaatst, die werkt al jaren naar behoren en je denk, daar heb ik geen omkijken naar.
Doch in de buurt ergens tussenin je draadloze link gaat men een nieuw gebouw gaan plaatsen. Het eerste wat je ziet op zo'n bouwwerf is een hijskraan.

De hijskraan belemmerd de point to point link en dit met als gevolg dat je data transfer fel verminderd en de latency de hoogte inschiet.
Door middel van het Mikrotik email bij hoge latency script kunnen deze problemen direct worden opgemerkt. Er zijn uiteraard nog vele voorbeelden maar in deze tutorial gaat het om de oplossing om direct te worden verwittigd.

Mikrotik email bij hoge latency

Hoe werkt het mikrotik email bij hoge latency script?

Het script kan worden geconfigureerd op het accespoint of Mikrotik router dat constant van internet is voorzien. Dit is dus punt A, punt B is de andere kant van de point to point link of bekabelde point to point link. Het script die geconfigureerd is op het AP of de router van kant A gaat op regelmatige basis een ping sessie gaan uitvoeren naar het IP-adres van kant B.

Ping gebruikt het ICMP-protocol om een ICMP ECHO REQUEST pakket te sturen naar host of gateway in afwachting van een reactie met een ICMP ECHO RESPONSE pakket. De reactietijd tussen het versturen en het ontvangen van de bevestiging wordt aangegeven als de round-trip time en wordt weergegeven in milliseconden.

Op deze manier kan de latency worden gemeten. Je kan de waarden in het script gaan aanpassen vooralleer je verwittigd wil worden. Indien de maximale tijd wordt overschreden wordt er een email verzonden. Of je kan een geluid signaal aansturen door middel van een Mikrotik router uitgerust met een PoE interface.

Het configureren van het mikrotik email bij hoge latentie script

mikrotik email bij hoge latentie
  1. Klik in het hoofdvenster op "system".
  2. Vervolgens op "Scheduler".
mikrotik email bij hoge latentie
  1. Klik op het blauwe kruisje bovenaan en bij"name" geef de scheduler taak een naam, bijvoorbeeld: To match latency time.
  2. Als "start date" vul een datum van vandaag in of een datum die nog moet komen.
  3. Vul eveneens bij "start time" een uur in dat nog moet komen, anders start de schedule taak niet.
  4. Bij interval kies hoeveel keer de controle moet plaats vinden. Bijvoorbeeld elke 1 minuut.
mikrotik email bij hoge latentie

Kopieer en bewerk het script naar uw wensen.

  1. plak het bewerkte script in het schedule venster.
  2. Klik op "ok".

Het email bij hoge latentie script

:local Themes "Monitor IP delay to alarmthreshold"
#Zet het te monitoren IP address hier onder.
:local addre 8.8.8.8;
#Zet de maximale vertraging hier onder in milliseconden.
:local ms 100;
:local avgRtt;
/tool flood-ping $addre count=10 do={
:if ($sent = 10) do={
:set avgRtt $"avg-rtt"
}}
:if ($avgRtt >= $ms) do={
#send mail
/tool e-mail send server=195.130.132.10 port=587user=uwusernaam password=uwpaswoord to=uwemail@gmail.com=uwemail@gmail.com
subject=$Themes body=("MonitoringIP:$addre\ndelay:$avgRtt ms")
:log err "Message has been sent";
}

Vergeet niet! Dit script werkt alleen maar bij Gmail.
Voor de email instellingen klik hieronder op de link.

x Shield Logo
This Site Is Protected By
The Shield →