Deel dit onderwerp alstublieft!

mikrotik groove vlan

mikrotik groove vlan

Mikrotik Groove VLAN met de nieuwe hardware off-loading implementatie is een ommezwaai betreft het configureren van VLANS op Mikrotik toestellen.

Ofschoon dit een goede poging is om de CPU minder te belasten staat deze techniek toch nog in zijn kinderschoenen.

Bij hw-offload moet je zodoende de master/slave configuratie namelijk niet meer instellen als je een switch configuratie aanmaakt.
Daarentegen moet je deze configuratie bijgevolg gewoon worden en de techniek zodoende onder de knie krijgen. 

Aangezien hardware offload nog in zijn kinderschoenen staat zou ik deze nog niet direct implementeren in een in bedrijf gestelde infrastructuur.

Je kan bijvoorbeeld wel een test opstelling opzetten en zodoende uitproberen om vast te stellen of alles naar behoren werkt.

Doch om duidelijkheid te scheppen begin ik de configuratie vervolgens vanaf nul.
En dit met screenshots en daarnaast met duidelijke uitleg.


mikrotik groove vlan configuratie met de nieuwe hardware off-loading implementatie zal vervolgens duidelijker worden na deze tutorial. 

Waar kan de Mikrotik Groove VLAN configuratie gebruikt worden?

De mikrotik groove vlan configuratie is zeer bruikbaar bij camping hotspots.
Ook op jachthavens staan deze op hun plaats.

Mits gebruik te maken van een Mikrotik binnen acces point kunnen die zelfs in hotels en zo meer in dienst worden genomen.

De mikrotik groove vlan configuratie kan dus vervolgens voor alle Mikrotik devices worden gebruikt.

Bovendien kunnen ze ook op paneel, grid, en sector antennes worden geschroefd.
De Mikrotik Groove is samengevat een universele en robuuste Wi-Fi radio.

Mikrotik Groove heeft één belangrijk zwak punt

In mijn geval was dat bij het plaatsen van een Groove in de buurt van een GSM/UMTS mast een ramp.

De Groove ontving en zond vervolgens helemaal geen signaal door.
Ik dacht eerst en vooral aan een defect maar bij het vervangen van de Groove was het resultaat juist hetzelfde.
 
Bijgevolg moest ik de Groove vervolgens vervangen door een Ubiquiti Bullet en daarmee was dit probleem opgelost. 

Conclusie de mikrotik Groove vlan configuratie kan in vele situaties worden gebruikt.
Maar niet in de buurt van een GSM/UMTS infrastructuur.
Dit is wel goed om weten.

Routerboard

RouterOs

Firmware

Default configuratie

Groove A-52HPn
hEX RB750r3

6.41

6.41

Nee

mikrotik groove vlan

Bron: http://www.aleetel.com

Wat is de opzet van deze VLAN configuratie

Met deze VLAN configuratie zal de Groove vervolgens 3 ssid's uitzenden.
Alle drie de SSID's hebben vervolgens een ander netwerk. 

Mits aanpassingen kan je de configuratie naar je hand zetten en zelf je
mikrotik groove vlan netwerk opzetten.

Dit kan uiteraard ook met alle Mikrotik toestellen zoals bijvoorbeeld de SXT series en zo meer. 
Ik wens je vervolgens veel configuratie en leer plezier toe.

Log zodoende in op de Mikrotik Groove met Winbox.

De configuratie van de Groove wireless interface

mikrotik groove vlan
  1. Klik in het hoofdvenster op "wireless".
  2. Dubbelklik op de wireless interface om de nodige instellingen te configureren.

Maak op de wireless interface de VLAN 200 aan.

mikrotik groove vlan
  1. Mode selecteer vervolgens "ap bridge". want dit wordt je acces point.
  2. Daar de Groove zowel de 2.4 GHz. en de 5 GHz. ondersteund selecteer je "2GHz.-B/G/N".
  3. Kies een gepaste ssid, als test geef ik daarom de naam vlan200.
  4. Verder schakel WPS-mode altijd uit om veiligheid redenen.
  5. Vervolgens selecteer de landinstellingen.
  6. Vervolgens afhankelijk van de antenne sterkte vul je het aantal dBi in van de antenne.
  7. Hier komt de VLAN iD te staan in dit geval is dit VLAN ID 200
  8. Tenslotte klik je op "ok".

Maak op de wireless interface de VLAN 300 aan.

mikrotik groove vlan
  1. Klik daarvoor op het blauwe kruisje.
  2. Verder klik je op "virtual".
    Vervolgens komt het venster hier onder te voorschijn.
mikrotik groove vlan
  1. Mits het hier gaat om een test geef de ssid de naam vlan300.
    Zo kan je later gemakkelijk de werking van de VLANS gaan testen.
  2. Als VLAN ID vul je 300 in.
  3. Ten slotte klik op "ok" om af te sluiten.

Maak op de wireless interface de VLAN 400 aan.

mikrotik groove vlan
  1. Klik terug op het blauwe kruisje om nog een virtueel acces point aan te maken.
  2. Vervolgens klik je terug op "virtual" waardoor het venster hieronder tevoorschijn komt.
mikrotik groove vlan
  1. Als ssid geef de naam vlan400 in.
  2. Vervolgens als VLAN ID vul je uiteraard 400 in.
  3. Klik op "ok".
mikrotik groove vlan

Alle wireless interfaces zijn vervolgens aangemaakt.
En hebben vervolgens hun eigen VLAN ID.

Nu moeten die nog in een bridge worden geplaatst met de bedoeling een VLAN TRUNK aan te maken, ken je vervolgens geen trunk kan je dit hier lezen.

Aanmaken van de trunk bridge op de Mikrotik Groove

mikrotik groove vlan
  1. Om de bridge aan te maken klik op het hoofdvenster op "bridge".
  2. Klik verder op het blauwe kruisje om de bridge aan te maken.
    Geef de bridge een naam. Ik laat bridge1 staan.
mikrotik groove vlan
  1. Klik vervolgens op het tabblad "VLANs".
mikrotik groove vlan
  1. Tijdens een VLAN configuratie met hw-offload schakel je de bridge filter uit.
    Dit voorkomt dat je de verbinding met je router gaat verliezen. Schakel vervolgens de bridge VLAN filter niet in op het einde van de configuratie. Het inschakelen van de bridge VLAN filter is alleen bij de CRS3xx series vereist. Doch als je dit wel zou doen wordt de HW-offloading nutteloos en gaat alle data verkeer terug via de CPU.
  2. Sluit vervolgens af door op "ok" te klikken.

Woord vooraf betreft deze bewerking interfaces in de bridge plaatsen

Hiermee plaats je de VLAN poorten in de bridge1 en geef je een VLAN-id aan de wlan interfaces.
VLAN-id betekend VLAN identificatie.

mikrotik groove vlan
  1. Geef de bridge de naam "bridge1".
  2. klik verder door naar het tabblad "VLAN"
mikrotik groove vlan
  1. Klik op het hoofdvenster op "bridge".
  2. Vervolgens klik verder op het tabblad "ports".
mikrotik groove vlan
  1. De bridge hoef je niet te selecteren omdat er geen andere bridge aanwezig is.
  2. Selecteer vervolgens "wlan1" om die in de bridge te plaatsen.
  3. Klik op "VLAN".
mikrotik groove vlan
  1. Vervolg met bij "PVID" 200 in te vullen.
  2. Verder klik je op "ok".
    Ter info PVID staat voor "Port VLAN Identificatie. De PVID heeft als functie een VLAN nummer aan een poort toe te wijzen. Zodoende krijgt alle verkeer dat untagged op die poort binnen komt een VLAN ID
mikrotik groove vlan
  1. Klik terug op het blauwe kruisje om "wlan2" in de bridge te plaatsen.
mikrotik groove vlan
  1. Vervolgens selecteer je "wlan2", 2- klik terug op "VLAN".
mikrotik groove vlan
  1. Verder vul je bij "PVID" 300 in.
  2. Klik vervolgens op "ok".
mikrotik groove vlan
  1. Om de laatste wireless interface "wlan3" in de bridge te stoppen klik eveneens op het blauwe kruisje.
mikrotik groove vlan
  1. Selecteer de interface "wlan3".
  2. Klik verder door op het tabblad "VLAN".
mikrotik groove vlan
  1. Vul bij "PVID" 400 in en 2- klik vervolgens op "ok".
mikrotik groove vlan
  1. Ten slotte voeg je de interface "ether1" in de bridge 2- en klik vervolgens op "ok".
mikrotik groove vlan
  1. De bridge1 is aangemaakt en alle nodige interfaces staan in de bridge. Deze interfaces hebben elk een eigen VLAN ID zodat deze via ether2 kan getransporteerd worden.

Tag ether1 als trunkpoort en untag  de wlan interfaces wlan1, wlan2, wlan3 in de vlan's.

Hierdoor tag je ether1 als trunkpoort en untag je de wlan interfaces wlan1, wlan2, wlan3 in de vlan's.

Tagged VLANS worden steeds gebruikt tussen twee switches of routers in het geval van Mikrotik.

Daardoor zal je zien dat de tagged VLAN steeds ether1 is in dit geval.
In de bridge wordt de tagged VLAN verwerkt naar untagged VLAN.

mikrotik groove vlan
  1. Klik in het hoofdvenster op "bridge" en vervolgens op 2 VLANs.
mikrotik groove vlan
  1. Bij bridge selecteer de aangemaakte "bridge1".
  2. Vervolgens geef je als VLAN ID 200 in.
  3. Bij Tagged selecteer je de ethernet interface "ether1". Weet je nog waarom?
  4. Als untagged interface selecteer wlan1.
mikrotik groove vlan
  1. Klik op het blauwe kruisje om de tagged en untagged interface voor VLAN 300 in te stellen.
mikrotik groove vlan
  1. Bij bridge selecteer de aangemaakte "bridge1".
  2. Vervolgens geef je als VLAN ID 300 in.
  3. Bij Tagged selecteer je de ethernet interface "ether1". Weet je nog waarom?
  4. Als untagged interface selecteer wlan2.
mikrotik groove vlan
  1. Klik op het blauwe kruisje om de tagged en untagged interface voor VLAN 400 in te stellen.
mikrotik groove vlan
  1. Bij bridge selecteer de aangemaakte "bridge1".
  2. Vervolgens geef je als VLAN ID 400 in.
  3. Bij Tagged selecteer je de ethernet interface "ether1".
  4. Als untagged interface selecteer wlan3.
mikrotik groove vlan
  1. Tot slot als alles goed is gegaan ziet de configuratie er als volgt uit. Opgelet! De configuratie die je net hebt gezien is alleen uitgevoerd voor de Mikrotik Groove.
mikrotik groove vlan
  1. Klik daarvoor op het tabblad "bridge".
  2. Vervolgens dubbelklik op "bridge1".
mikrotik groove vlan
  1. Verder klik je door op "VLAN".

Laat de VLAN filtering uit bij deze model router boarden.
Als je de filter aanzet wordt in deze modellen switch-chips
De Hw-offload uitgezet en verloopt alles via de CPU.
Zie de tabel onderaan het vorig bericht.
Voor meer informatie
Dit is wat betreft de configuratie van de mikrotik groove vlan
Nu moet je nog beginnen aan de configuratie van het routerboard hEX RB750r3.
Dit zet ik wel verder in de CLI modus want dit gaat stukken vlugger.
Je moet namelijk niets anders doen dan de code in de new terminal plakken. 

VLAN configuratie van het hEX RB750r3 

/interface bridge
add name=bridge1 vlan-filtering=no
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=wlan1 pvid=200
add bridge=bridge1 interface=wlan2 pvid=300
add bridge=bridge1 interface=wlan3 pvid=400
/interface bridge vlan
add bridge=bridge1 tagged=ether1 untagged=wlan1 vlan-id=200
add bridge=bridge1 tagged=ether1 untagged=wlan2 vlan-id=300
add bridge=bridge1 tagged=ether1 untagged=wlan3 vlan-id=400

Zo de configuratie van de hEX RB750r3 is al klaar.
Ofschoon de Groove configureren langer duurde ken je nu wel de basis en de manier van configureren met hardware off-load.
Ik hoop dat je er iets uit hebt geleerd.