Deel dit onderwerp alstublieft!

Mikrotik netwatch alarm

Mikrotik netwatch is een veelzijdige tool waarmee je onder ander de PoE out interfaces van je Mikrotik router kan in en uitschakelen.
En in dit geval ga ik deze functie niet gebruiken om een accespoint in en uit te schakelen maar om een alarm signaal in en uit te schakelen bij een defect op je netwerk. 

Dit maakt het voor de IT'er toch wat eenvoudiger een netwerk fout op te sporen. Hier ga ik je laten zien hoe een Mikrotik netwatch alarm gemaakt kan worden met verschillende signalen. Dit kan een flitslicht, geluidsignaal of op een controle paneel met controle lampjes worden ineen gemonteerd worden.

Mits gebruik te maken van een 12 of 24 volt DC relais kan je zelfs alle kanten uit. Kortom de toepassingen van het Mikrotik netwatch alarm kan veelzijdig worden gebruikt.

Opgelet! Deze tutorial is uitsluitend gemaakt op basis van de Mikrotik routers en niet bedoeld voor de managed PoE switchen. De voeding van de Mikrotik router speelt dan ook een grote rol in deze tutorial.

Mikrotik netwatch alarm

Welke voeding is geschikt voor de Mikrotik netwatch alarm configuratie

maenwell-ad155-b voeding


De Meanwell voedingen zijn zeer geschikt om zowel de router en het alarm signaal te voeden. Maar deze moeten dan worden afgeregeld naar 12 volt voor het AD-105A model. Of bij de zwaardere AD-105B moet je deze gaan afregelen naar 24 volt DC.

Nog een eigenschap van deze voedingen is dat je backup batterijen kunt gebruiken om deze bij een stroomuitval alsnog je toestellen een tijd van stroom te voorzien. Ikzelf ben zeer tevreden over deze bedrijfszekere DC voedingen.

Opgelet voor de namaak Meanwell voedingen! Ze zien er bijna hetzelfde uit maar de kwaliteit is een ander paar mouwen.  

Wat kan je zoal gebruiken als alarm signaal en waar moet je zeker rekening mee houden

Om de Mikrotik netwatch alarm configuratie te doen slagen gebruik ik het liefst een relais met een spoel dat weinig stroomsterkte nodig heeft. Je kan uiteraard  een flitslamp zoals deze van Velleman gebruiken. In de video tutorial zie je een voorbeeld met deze flitslamp. Deze heeft ook een geringe stroomsterkte want de PoE output van je Mikrotik router is uiteraard beperkt. Op deze manier belast je de PoE poort zo weinig mogelijk en kunnen de PoE componenten niet beschadigd raken.

Je kan ook een geluidssignaal gebruiken zoals een buzzer maar denk aan de stroomsterkte beperking van de router. Daarom geniet een relais mijn voorkeur.
De relais kan meerdere signalisatie toestellen sturen en de PoE belasting wordt beperkt tot de relais zelf. 

Power over ethernet welke aders worden er gebruikt bij de netwerkkabel voor de + en - pool

Mikrotik netwatch alarm


De originele technologie staat bekend onder de naam IEEE 802.3af. De opvolger van PoE is de IEEE 802.3at-standaard beter gekend als PoE+. En worden bij de standaard PoE switchen gebruikt.

Deze standaard gebruikt vier aders. Deze vier aders worden gebruikt voor zowel data- als stroomoverdracht.
Maar OPGELET! deze IEEE 802.3 standaarden kan je niet gebruiken bij deze tutorial.

Bij Mikrotik routers wordt de PoE stroom voorzien door de aangesloten voeding. En het is deze manier van power over ethernet dat je moet gaan gebruiken om de alarm toestellen te activeren.

Om dit duidelijk te illustreren heb ik een afbeelding gemaakt, want bij dit project is de polarisatie van groot belang.  

Indien je een geluid signaal wil als Mikrotik netwatch alarm let op de voltage 


Er zijn natuurlijk veel buzzers zoals deze op de afbeelding hiernaast. Deze heeft als eigenschap dat de werkspanning vanaf 1.5 volt tot 24 volt DC aankan. Dit maakt deze buzzer tot een universeel inzetbare buzzer.

Het is natuurlijk aan te raden om een schakelaar tussen de PoE uit en de buzzer te plaatsen anders blijft deze geluid geven totdat het defect is opgelost.

Mikrotik netwatch alarm

Aan welke vereisten moet de relais voldoen voor dit project

Mikrotik netwatch alarm


Hoeveel de werkspanning moet zijn van de relais hangt af van de gebruikte voeding waarmee je uw Mikrotik router van stroom voorziet. 
Indien deze 24 volt DC is moet de relais uiteraard ook 24 volt DC ondersteunen. Voor relais met een nog hogere werkspanning kan je eventueel eens vragen aan een verdeler.

Opgelet er bestaan ook relais met een spanning van 24 volt AC dit betekend wisselspanning en daar kan je niets mee aanvangen. DC betekend gelijkspanning en die heeft dus een + en - pool.

Er bestaan natuurlijk ook 12 volt relais maar de keuze wordt bepaalt welke voeding je gebruikt om je Mikrotik router te voeden. Het liefst maak ik gebruik van 24 volt omdat de stroomsterkte tegenover de 12 volt relais halveert. Daardoor wordt de belasting van het PoE circuit flink verminderd. 

Voorbeeld schema van de sturing van een zwaarder licht alarm 

Mikrotik netwatch alarm

Hoe werkt het Mikrotik netwatch alarm en welk script heb je nodig

Mikrotik netwatch is een tool die door jou ingestelde IP-adressen kan gaan pingen. Naargelang het ingegeven script kan je een email versturen als dit IP-adres niet meer bereikbaar is. Maar bij de Mikrotik netwatch alarm configuratie schakel je de PoE uit interface in als het IP-adres niet meer bereikbaar is en uit indien deze wel bereikbaar is.

Het wordt pas interessant als je bijvoorbeeld een email kan gaan zenden en ook een licht of geluidsignaal kan gaan sturen. Kortom je kan er creatieve en bruikbare dingen mee aanvangen. In de plaats van een lichtflitser aan te sturen kan je bijvoorbeeld ook controle lampjes gaan sturen die groen branden als alles ok is en rood branden als het betreffende IP-adres niet meer bereikbaar is.

Wat kan je allemaal gaan pingen? alles dat in verbinding staat met de router met PoE uit poorten of poort. Bijvoorbeeld is het internet bereikbaar, is de backup server bereikbaar, zijn de bewakingscamera's online en ga zo maar door.

Kortom de Mikrotik netwatch alarm configuratie kan voor vele oplossingen dienst doen en er voor zorgen dat je bij elk defect direct verwittigd wordt.  

Mikrotik netwatch alarm UP

/interface ethernet poe set ether2 poe-out=off

Mikrotik netwatch alarm DOWN

/interface ethernet poe set ether2 poe-out=forced-on

Dit is wat betreft de Mikrotik netwatch alarm configuratie. Let op dat je alles juist aansluit of je kan je router beschadigen. Ik ben in geen geval aansprakelijk voor schade aan uzelf, de router en andere toestellen. In deze blogpost geef ik nog wat voorbeelden van nuttige scripts. Ik wens je alvast veel configuratie plezier.

Schakel een ventilator in en uit in je 19" rack of aan je Mikrotik router indien deze te warm wordt

Voor dit script is natuurlijk twee vereisten, ten eerste moet de Mikrotik router over een temperatuur meter beschikken. Ten tweede moet de router over een PoE-out beschikken. De ventilator wordt door middel van een relais geschakeld, die schakelt de ventilator in en uit als bepaalde temperaturen worden bereikt.

Door deze relais is het zelfs mogelijk 220 volt ventilatoren aan te sturen en deze is volledig onafhankelijk van de PoE-out. Daarvoor kan de werkloze PoE-out interface van je Mikrotik router ook worden gebruikt. Met de vorige toepassing is er één groot verschil dat de temperatuur gemeten wordt door dezelfde router met de PoE-out interface. Een prachtige toepassing is het niet?

Maak 3 scripts aan en kopieer en plak deze onderstaande scripts in een nieuw script venster.  

Start-up

interface ethernet set ether5 poe-out=off

Eerst en vooral moet dit script exact dezelfde naam hebben (Start-up) vervolgens kopieer en plak dit bovenstaand srcipt in het script venster.
Deze zorgt namelijk bij het opstarten dat er geen valse alarmen worden gegeven. Of in dit geval dat de ventilator onnodig begint te draaien.

Temperatur-PoE-off

:if ([/system health get temperature] <= 30) do={interface ethernet set ether5 poe-out=off
}

Als de temperatuur is gezakt naar 30 graden gaat de PoE-out interface geen stroom meer geven. De ventilator draait niet meer.
Deze temperatuur kan je zelf gaan bepalen door de 30 te wijzigen in het script.

Temperatur-PoE-on

:if ([/system health get temperature] >= 40) do={interface ethernet set ether5 poe-out=forced-on
}

Indien de temperatuur boven de 40 graden komt zal de PoE-out interface van stroom worden voorzien. De ventilator zal beginnen draaien.
Deze temperatuur is eveneens door jezelf te bepalen. 

Scheduller script

/system scheduler
add interval=10s name=Temperatur-PoE-on on-event=Temperatur-PoE-on start-date=mar/22/2019 start-time=15:30:00
add name=Start-up on-event=Start-up policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon start-time=startup
add interval=8s name=Temprature-PoE-off on-event=Temperatur-PoE-off start-date=mar/22/2019 start-time=15:30:00

Plak dit script in het "new terminal venster.

Hou rekening met de configuratie van de NTP-cliënt om het uur juist in te stellen. Dit script is getest en werkend bevonden. Natuurlijk zijn er ook 19" rack ventilatoren met eigen thermostaat, doch dit is om je een idee te geven wat je allemaal kan aanvangen met de routers en hun PoE-out interface. 

Steun WirelessInfo.be

Om de hosting en de plugin kosten te dekken geef een kleine schenking alstublieft