Deel dit onderwerp alstublieft!

1km linktest met SXT G-5HPacD

Eigenschappen van de infrastructuur

RouterOS versie 6.44.3
Firmware 6.44.3
Signaal -46
Cliënt Connection Quality 98%

Situatie schets

1km linktest met SXT G-5HPacD

1km linktest met SXT G-5HPacD linktest is uitgevoerd volgens de wettelijke limit op 1 watt eirp. En met een bandbreedte van 80 MHz wat niet aangeraden is.
De snelheid tussen beide SXT's word gemeten met de Mikrotik bandwidth tool op twee extra routers. Dit om correcte metingen te kunnen uitvoeren.
 
Verder is deze test is uitgevoerd op een openbare weg aan de haven van Gent. Beide SXT's staan op 3.80 meter hoogte van de grond, gemonteerd op een luidsprekerstandaard. Bij het nemen van een site survey zie ik 2 andere acces points actief, met een signaal van -84 dB, dit kan enigszins wat storingen veroorzaken.
 
Weliswaar was het de bedoeling met twee man deze 1km linktest met SXT G-5HPacD uit te voeren doch ik had geen hulp. Daardoor kon ik geen uitgebreide wifi linktesten uitvoeren. 

OPGELET!
 Ik heb toestemming gekregen om het havengebied te betreden, doe dit dus niet zonder toestemming. Een havengebied betreden mag niet zonder toestemming van de
bevoegde personen. Ik moet hier strikte reglementen naleven.

1km linktest met SXT G-5HPacD
1km linktest met SXT G-5HPacD

Situatie kort geschetst

Schema aansluiting

De Mikrotik SXT G-5HPacD r2 heeft een gigabit ethernet interface waardoor ik een goed zicht heb op de werkelijke snelheid. Deze Mikrotik SXT's zijn half duplex.
Dit wil zeggen dat deze niet tegelijkertijd kunnen zenden en ontvangen. De SXT zend eerst data pakketten uit en eens deze zijn verstuurt schakelt die om op ontvangen. 

Zoals al aangehaald maak ik gebruik van 2 extra routers om de CPU van de SXT's niet te belasten met de Mikrotik bandwidth tool. Deze is nogal CPU intensief.
Op deze manier kan ik op de wifi link test correctere metingen uitvoeren en krijg je een duidelijker beeld van de behaalde snelheid. En dit zonder dat de CPU de snelheid gaat onderdrukken.

1km linktest met SXT G-5HPacD

Link plan 1km linktest met SXT G-5HPacD

Plan afstand 1 Km

Op deze link planning kan je zien dat deze weg precies 1 Km bedraagt. Dit maakt dat deze weg één van mijn favoriete plaats is om deze 1km linktest met SXT G-5HPacD linktest uit te voeren. Deze wifi linktest is op een zondag gebeurd omdat er dan zeer weinig verkeer is op deze weg. Nogmaals ik heb daarvoor toelating gekregen. 

Wat afbeeldingen van de opstelling van de Mikrotik infrastructuur

wifi link test opstelling

Deze opstelling is vrij eenvoudig, de SXT wordt gevoed door een 24 volt batterij en is aangesloten op de flightcase met een Mikrotik RB2011. Deze fungeert als de cliënt.
Uitrichten is hier geen probleem omdat de 5 GHz. op 1 Km afstand nog gemakkelijk uit te richten is. Dit in vergelijking met de 60 GHz Frequentie is dat nog kinderspel.

Doch moet ik rekening houden met de gebruikte netwerkkabel. Een slechte netwerkkabel gaat namelijk de 1Gbit snelheid niet behalen en dit is dus ook een punt waar je dient rekening meer te houden. De 1km linktest met SXT G-5HPacD is uitgevoerd op 20-12-2015. Waarom ik dit vertel zie je later in deze uiteenzetting.

Flightcase met de voorziene 24 volt voeding en Mikrotik router

wifi link test

In de wagen staat een flightcase met een 24 volt batterij. Deze kan zowel de SXT als de ingebouwde Mikrotik router voeden. Met de laptop log ik in op de Mikrotik router met Winbox om de snelheid te gaan meten met de bandwidth test.

Opstelling tegen station

Het tegen station word ook gevoed met een 24 volt batterij en daar is eveneens een Mikrotik RB2011 aangesloten. Doch je ziet de router niet op deze afbeelding.
Zoals je ook kan zien is de opstelling gezekerd met touwen aan de paal om niet omver te waaien. Veiligheid staat bij deze wifi link testen op hoge prioriteit en terecht.   

1km linktest met SXT G-5HPacD

Het resultaat van 1km linktest met SXT G-5HPacD met het 802.11 ac protocol TCP 80MHz. bandbreedte 

1km linktest met SXT G-5HPacD

Aangezien ik hier een meting uitvoer met een bandbreedte van 80 MHz. behaald deze niet de verwachte snelheden. Hoe dat komt? Een Point to Point link dient niet op een dergelijke bandbreedte te gebeuren maar op een maximale bandbreedte van 40 MHz. Ik geef zelfs liever de voorkeur aan 20 MHz. bandbreedte. Deze wifi linktest bewijst dat de nodige stabiliteit niet kan worden verkregen door een hogere bandbreedte in te stellen. Onthoud dat goed. 

Resultaat met het 802.11 ac protocol UDP 80Mhz. bandbreedte.

Resultaat wifi linktest

UDP heeft meer snelheid bij deze 1km linktest met SXT G-5HPacD. Maar zie links bij lost packets. Dit komt omdat er geen limit is ingesteld op deze wifi link. Zodoende wordt steeds de uiterste snelheid gevraagd waardoor er veel packet loss ontstaat. Dit is ook een leerschool, vraag niet steeds het uiterst van een Point to Point link.
Hoe je wifi link te optimaliseren kan je hier zien, ga naar punt 6

1km linktest met SXT G-5HPacD

De ping tijden en packet loss zijn hier uitstekend bij een niet belast draadloos netwerk. Maar dat is vrij normaal gezien de ping pakketjes zeer klein zijn.
Ping gebruikt het ICMP-protocol om een ICMP ECHO aanvraag pakket te sturen naar de host (in dit geval de Mikrotik 2011 van het tegen station) in afwachting dat het tegen station een reactie met een ICMP ECHO antwoord terugstuurt. De tijd dat de ping daarover doet noemt men de latency.

Configuratie 802.11 ac protocol- AP

/interface bridge add name=bridge1
/interface wireless
set [ find default-name=wlan1 ] antenna-gain=16band=5ghz-onlyac channel-width=\20/40/80mhz-eCee country=belgium disabled=nofrequency=5600
guard-interval=\long l2mtu=1600 mode=ap-bridgessid=sxt-ac-ap tx-power-mode=all-rates-fixed \wireless-protocol=802.11
/interface wireless security-profiles set [ find default=yes] supplicant-identity=MikroTik
/system logging action set 2 remember=yes
/interface bridge port
add bridge=bridge1 interface=wlan1
add bridge=bridge1 interface=ether1
/ip dhcp-client add dhcp-options=hostname,clientiddisabled=no interface=bridge1
/ip upnp set allow-disable-external-interface=no
/snmp set trap-community=public
/system identity set name=sxt-ap
/system leds set 0 interface=wlan1
/system routerboard settings set cpu-frequency=720MHz

Configuratie 802.11 ac protocol- Cliënt

/interface bridge add name=bridge1
/interface wireless
set [ find default-name=wlan1 ] antenna-gain=16band=5ghz-a/n/ac channel-width=\ 20/40/80mhz-eCee country=belgium disabled=nofrequency=5600 l2mtu=1600
mode= station-bridge ssid=sxt-ac-aptx-power-mode=all-rates-fixed wds-default-bridge=bridge1 wds-mode=dynamicwireless-protocol=802.11
/interface wireless
security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/system logging action set 2 remember=yes
/interface bridge port
add bridge=bridge1 interface=wlan1
add bridge=bridge1 interface=ether1
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=nointerface=bridge1
/ip upnp set allow-disable-external-interface=no
/snmp set trap-community=public
/system identity set name=sxt-client
/system leds set 0 interface=wlan1
/system routerboard settings set cpu-frequency=720MHz
Resultaat op 802.11 ac protocol TCP
De SXT-G-5HPacD staat 1 km uit elkaar op een hoogte van 3 meter. Dit op een rustige weg in de Gentse haven.
De Mikrotik SXT G-5HPacD r2 heeft een gigabit ethernet interface waardoor we een goed zicht hebben op de link snelheid. Om de CPU van de SXT niet te belasten door de bandwidth test software, draaien we deze niet op de SXT zelf. We sluiten de SXT aan op een routerboard RB2011 UiAS-2HnD-in. Deze wordt de DHCP-server en een RB2011-rm aan de andere kant ingesteld als client. Op deze routerboarden wordt gemeten welke snelheid de draadloze wifi link behaald. Deze linktest is afgenomen in een rustig gebied. Er is een site survey uitgevoerd, er is een zijn 2 accesspoints gezien met een signaal van -84 dB
1km linktest met SXT G-5HPacD

Mijn inzien kan de link wat beter door gebruik te maken van een kleinere bandbreedte  waardoor de link stabieler zal worden. Dit kan je uitproberen op jullie Point to Point wifi link. Op deze manier kan je zien wat het beste resultaat is want iedere situatie is anders en vraagt een andere aanpak van configuratie of opstelling. 

Dit betekent dat zowel  11n als oudere apparaten kunnen deelnemen aan hetzelfde netwerk en het niet nodig is om hardware te upgraden om Nv2 in het netwerk te implementeren.

Resultaat van 1km linktest met SXT G-5HPacD met het Nv2 ac protocol TCP 80Mhz. bandbreedte

wifi link test resultaat

De snelheid van deze 1 Km wifi linktest is hier wat minder van snelheid dan bij het 802.11ac protocol. Dit kan uiteraard liggen aan het niet finetunen van de wifi link.

wifi link test

Bij UDP is de snelheid heel wat minder, maar de packet loss is hier ook een pak minder wat eigenlijk beter is. In de toekomst zal ik alsnog proberen om wifi link testen uit te voeren en indien ik hulp heb spit ik deze wat dieper uit. Doch als je verder leest zal je zien dat Nv2 niet lang meer zal overleven. Dit door modernere draadloze protocols.

Ping test met het Nv2 protocol heeft meer latency

wifi link test resultaat

Ping test zowel voor TCP als UDP met 0% packet loss maar grotere latentie. Ik heb de indruk dat het Nv2 protocol dan nog moest worden gefinetuned.  
Doch met de nieuwe 802.11 ac technologie behoort Nv2 tot de oude generatie protocols. Alle SXT's die vroeger werden voorzien van een  MMIPS CPU zijn nu vervangen

De Mikrotik toestellen worden meer en meer uitgerust met een ARM CPU waardoor Nv2 zo goed als onbruikbaar wordt. Mikrotik ziet dit niet als een beperking en op deze manier zal het door Mikrotik ontworpen Nv2 protocol vervangen worden door het 802.11ac protocol. Of dit nu goed nieuws is laat ik aan jullie over.

Accespoint Nv2 protocol configuratie

/interface bridge add name=bridge1
/interface wireless
set [ find default-name=wlan1 ] antenna-gain=16band=5ghz-onlyac channel-width=\20/40/80mhz-eCee country=belgium disabled=nofrequency=5600
guard-interval=\long l2mtu=1600 mode=ap-bridgessid=sxt-ac-ap tx-power-mode=all-rates-fixed \wireless-protocol=NV2
/interface wireless security-profiles set [ find default=yes] supplicant-identity=MikroTik
/system logging action set 2 remember=yes
/interface bridge port
add bridge=bridge1 interface=wlan1
add bridge=bridge1 interface=ether1
/ip dhcp-client add dhcp-options=hostname,clientiddisabled=no interface=bridge1
/ip upnp set allow-disable-external-interface=no
/snmp set trap-community=public
/system identity set name=sxt-ap
/system leds set 0 interface=wlan1
/system routerboard settings set cpu-frequency=720MHz

Client Nv2 protocol configuratie

/interface bridge add name=bridge1
/interface wireless
set [ find default-name=wlan1 ] antenna-gain=16band=5ghz-a/n/ac channel-width=\ 20/40/80mhz-eCee country=belgium disabled=nofrequency=5600 l2mtu=1600
mode= station-bridge ssid=sxt-ac-aptx-power-mode=all-rates-fixed wds-default-bridge=bridge1 wds-mode=dynamicwireless-protocol=NV2
/interface wireless
security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/system logging action set 2 remember=yes
/interface bridge port
add bridge=bridge1 interface=wlan1
add bridge=bridge1 interface=ether1
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=nointerface=bridge1
/ip upnp set allow-disable-external-interface=no
/snmp set trap-community=public
/system identity set name=sxt-client
/system leds set 0 interface=wlan1
/system routerboard settings set cpu-frequency=720MHz

Steun WirelessInfo.be

Om de jaarlijkse kosten wat te helpen dragen stort een kleine bijdrage op de Paypal rekening alstublieft.
Deze bijdrage wordt gebruikt om de hosting, bepaalde plugin's en hardware te financieren.

Pingtest zowel voor TCP als UDP met 0% packet loss.
Resultaat op 802.11 ac protocol UDP 80Mhz. bandbreedte

Het Nv2-protocol is een eigen draadloos protocol dat is ontwikkeld door MikroTik.

Het is speciaal ontworpen voor gebruik met draadloze chips van het type Atheros 802.11.

 

 Nv2 is gebaseerd op TDMA (Time Division Multiple Access) mediatoegangstechnologie in plaats van CSMA (Carrier Sense Multiple Access) mediatoegangstechnologie die wordt gebruikt in reguliere 802.11-apparaten.

TDMA-mediatoegangstechnologie lost een verborgen knooppuntprobleem op en verbetert het mediagebruik, waardoor de doorvoer en latentie worden verbeterd, vooral in PtMP-netwerken.

Nv2 wordt ondersteund voor Atheros 802.11n-chips en oudere 802.11a / b / g-chips vanaf AR5212, maar wordt niet ondersteund op oudere AR5211- en AR5210-chips.

 

Dit betekent dat zowel - 11n als oudere apparaten kunnen deelnemen aan hetzelfde netwerk en het niet nodig is om hardware te upgraden om Nv2 in het netwerk te implementeren.

Mediatoegang in het Nv2-netwerk wordt bestuurd door het Nv2 Access Point.

Nv2 AP verdeelt tijd in "periodes" met een vaste grootte die dynamisch zijn onderverdeeld in downlink en up-link op basis van wachtrijstatus op AP en cliënts.

 

 Up-link tijd wordt verder verdeeld tussen verbonden cliënts op basis van hun vereisten voor bandbreedte. Aan het begin van elke periode zendt AP een schema uit dat cliënts vertelt wanneer ze moeten verzenden en hoeveel tijd ze kunnen gebruiken.

Om nieuwe cliënts toe te staan om verbinding te maken, wijst Nv2 AP periodiek up-link tijd toe aan "niet-gespecificeerde" cliënts.

 

Dit tijdsinterval wordt dan door de nieuwe cliënt gebruikt om registratie bij het AP te initiëren.

Vervolgens schat het AP de voortplantingsvertraging tussen AP en cliënt in.

 en begint periodiek een up-linktijd voor deze cliënt te voltooien om de registratie en gegevens van de cliënt te ontvangen.

 

Nv2 implementeert dynamische tariefselectie per cliënt en ARQ voor datatransmissies. Dit maakt betrouwbare communicatie over Nv2 verbindingen mogelijk.

Voor QoS implementeert Nv2 een variabel aantal prioriteitswachtrijen met ingebouwde standaard QoS-planner die kan worden gecombineerd met een fijnmazig QoS-beleid op basis van firewallregels of prioriteitsinformatie die via het netwerk wordt doorgetrokken met behulp van VLAN-prioriteit of MPLS EXP-bits.

Nv2-protocollimiet is 511 cliënts per interface.