Deel dit onderwerp alstublieft!

Mikrotik nv2 protocol

Het Mikrotik nv2 protocol gebruiken als je een Point to Multi Point wil gaan configureren heeft veel voordelen. En dit omdat het de data doorvoer positief gaat beïnvloeden. Het Mikrotik nv2 protocol is gerelateerd aan Mikrotik. Dit wil zeggen indien je het Mikrotik nv2 protocol wil gebruiken je Mikrotik toestellen nodig hebt. 
Een Point to Point of Point to Multi Point verbinding haalt de beste prestatie indien je gebruikt maakt van één fabrikant. En dat geld voor ieder merk. Maar aangezien het nv2 protocol samen werkt met het TDMA-protocol is dit een zeer goede zaak. Ik wil je eerst informeren wat de TDMA betekent voor het nv2 protocol.

Mikrotik nv2 configuratie

Het Mikrotik nv2 protocol en de rol van de Time Division Multiple Access 

TDMA staat voor Time Division Multiple Access en is een techniek om data botsingen of in het netwerk jargon te gezegd data collisions te voorkomen. Deze collisions worden voorkomen door iedere cliënt een vaste tijd te geven om hun data te verzenden. Dit is in vergelijking met de 802.11 CSMA/CA techniek een echte aanrader. Met andere woorden is de TDMA techniek veel doeltreffender. Het Mikrotik nv2 protocol is daardoor bedrijfszeker en betrouwbaar.

Mikrotik nv2 protocol

Hoe gaat TDMA te werk op een Point to Multi Point configuratie

De Mikrotik Omnitik heeft als AP de leiding als het nv2 protocol is ingeschakeld. Deze gaat eerst kijken hoeveel cliënts er zijn verbonden. In bovenstaande tekening zijn dit er twee. De TDMA techniek zorgt ervoor dat de data verzonden door de twee cliënts naar de Omnitik niet tegelijkertijd plaatsvind. Anders ontstaat er een data botsing. Om deze data collisions te voorkomen geeft TDMA aan elke cliënt een vaste tijd waarin hij de data kan gaan verzenden en ontvangen. Op deze manier worden data collisions voorkomen. Deze cyclus wordt steeds herhaald en zo krijgt iedere cliënt de gelegenheid om zijn data te gaan zenden en te ontvangen. Je kan wel goed verstaan waarom ik het Mikrotik nv2 protocol aanbeveel. Doch wat gebeurd er als er een cliënt wordt bijgevoegd. Dit maak ik je duidelijk in het volgend hoofdstuk.

Wat doet TDMA indien een extra cliënt wordt toegevoegd

Indien een extra cliënt wordt toegevoegd voegt TDMA periodieke uplink-tijden toe. Dit om de nog niet gespecificeerde cliënt de tijd te geven zich bekend te maken. Eens het accespoint de tijd heeft bepaald zal deze de afstand schatten. Het accespoint zend daarvoor een aanvraag naar de cliënt en wacht daarna naar het antwoord.
Dus de cliënt zend een antwoord terug naar het accespoint. Afgaand op de tijd dat nodig is om het antwoord te ontvangen kan het AP de afstand schatten. De cliënt word ingecalculeerd in de point to Multi point verbinding. Op deze manier wordt de tijdsperiode van de cliënt geïmplementeerd in de Mikrotik nv2 wifi link.

Je moet wel de afstand ingeven en dit doe je door op het NV2 tabblad te klikken. Opgelet! indien je dit niet ziet staan klik je op het tabblad "advanced mode".

TDMA advanced settings

Indien je een nv2 Point to Multi Point configureert en je wil dat de beste verbonden cliënts voorrang krijgen selecteer dan bij "TDMA period" "auto". Met deze instelling zorgt TDMA ervoor dat de cliënts met de beste kwaliteit verbinding voorrang krijgen. De slechtere linken worden achteraan gehouden. 

Mikrotik nv2 instellingen

Het Mikrotik nv2 protocol heeft langere ping tijden maar dit hoeft niet nadelig te zijn 

Daar de tijd per cliënt is bepaald kan het zijn dat de ping tijden wat omhoog gaan en dit is normaal. Maar dit wil niet zeggen dat je data doorvoer minder goed is integendeel. Het Mikrotik nv2 protocol heeft als eigenschap geen enkele data botsing  te hebben en dit kan alleen maar goed zijn voor de data doorvoer is het niet.
Wat telt bij het nv2 protocol is de bedrijfszekerheid en throughput van de Point to Multi Point verbinding.

Mikrotik nv2 protocol en de draadloze beveiliging 

Je moet zeker weten dat het nv2 protocol geen gebruik maakt van de gebruikelijke security profile op de Mikrotik toestellen. In plaats daarvan gebruikt het nv2 protocol een hardware versnelde  gegevenscodering door middel van een AES-CCM 128 bits sleutel. En dit met behulp van een 4-way hand shake. Dus de veiligheid is optimaal. 
Je kan maximaal een paswoord gaan invullen van 64 karakters. Dit is gelijk aan de gewone WPA2 pre shared Key sleutel.

De afstand wordt achterhaald door nv2

De afstand van de Point to Multi Point link wordt achterhaald door het nv2 protocol. Hoe gebeurd zoiets? Het accespoint gaat een vraag verzenden naar de desbetreffende cliënts "zend me alstublieft een antwoord zodat ik de tijd kan berekenen". Het acces point zal de tijd onthouden wanneer deze zijn aanvraag heeft verzonden en berekenen hoeveel tijd er is overgegaan totdat hij het antwoord heeft ontvangen van de cliënts. Op deze manier kan het Mikrotik nv2 protocol de afstand berekenen. Je hoeft bij de "advanced mode" geen afstand in te geven. De tijd van het verzenden van de vraag en het ontvangen van het antwoord wordt de round trip tijd genaamd. Dit is ook zo met het ping commando.   

Wat doet Mikrotik nv2 met de slecht ontvangen frames

Mikrotik nv2 implementeert dynamische snelheidsselectie en Automatic Repeat Requests per cliënt. Dit is een techniek dat gebruikt wordt om de slecht ontvangen pakketten terug aan te vragen. Er wordt ook een tijd ingecalculeerd voor deze procedure.

Hou rekening met de RouterOS versie op alle Mikrotik toestellen

Voorzie alle Mikrotik toestellen die betrokken zijn in de Point to Multi Point configuratie van dezelfde RouterOS versie. Dit is zeker aangewezen. Waarom vraag je je misschien af? Omdat Mikrotik nog steeds aan het sleutelen is aan de software die op deze toestellen draait.  Hoe je een up of downgrade uitvoert zie je hier. Dit is alvast een eerste stap die je moet gaan maken om de Point to Multi Point configuratie tot een goed einde te brengen. 

Wat voor licentie is er nodig voor een Point to Multi Point wifi link

Bij Point to Multi-point verbindingen moet het accespoint over een licentie 4 beschikken. Een Dynadish voldoet dus niet want deze heeft RouterOS licentie 3.
Deze zijn ontworpen om Point to Point links te verwezenlijken. En dit is maar goed zo omdat de stralingshoek klein is en zodoende niet geschikt voor een PtMP link.
Let dus goed op welke licentie het Mikrotik toestel heeft. Meer weten over het aankopen van een Mikrotik router? Lees deze uiteenzetting op deze blogpostJe kan de licentie gaan upgraden naar een RouterOS licentie 4 om een Point to Multi-point verbinding te verwezenlijken. Hoe je dit doet kan je hier zien. Er zijn nog belangrijke onderwerpen over Point to Point links zoals de wifi wetgeving. Ik geef je alvast de raad om deze blogpost ook eens te bekijken.

De configuratie van de Point to Multi Point link met het Mikrotik nv2 protocol

De Mikrotik Omnitik PG-5HacD is geschikt om een Point to Multi Point te demonstreren. Zoals al ik al heb aangehaald gaat de Mikrotik Omnitik de leiding nemen.
De twee Mikrotik SXTsq5AC zijn de cliënts en worden gedelegeerd door de Omnitik. Het Mikrotik nv2 protocol gaat er voor zorgen dat iedere cliënt zijn zegje kan doen.

Point to Multi Point
RouterOS versie 6.47.3
Bios versie 6.47.3

Configuratie script Omnitik

/interface bridge
add name=bridge1
/interface wireless
set [ find default-name=wlan1 ] band=5ghz-onlyac country=belgium disabled=no frequency=5680 mode=ap-bridge nv2-preshared-key=testtest nv2-security=enabled ssid=MikroTik-nv2-PtMP tdma-period-size=auto wireless-protocol=nv2
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether5
add bridge=bridge1 interface=wlan1
/ip address
add address=192.168.88.2/24 interface=bridge1 network=192.168.88.0
/ip dhcp-client
add disabled=no interface=bridge1
/ip route
add distance=1 gateway=192.168.88.1
/system identity
set name=PtMP-AP

Client1 SXT configuratie script

/interface bridge
add name=bridge1
/interface wireless
set [ find default-name=wlan1 ] band=5ghz-a/n/ac country=belgium disabled=no frequency=5680 mode=station-bridge nv2-preshared-key=testtest nv2-security=enabled ssid=MikroTik-nv2-PtMP wireless-protocol=nv2
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/interface bridge port
add bridge=bridge1 interface=wlan1
add bridge=bridge1 interface=ether1
/ip address
add address=192.168.88.3/24 interface=bridge1 network=192.168.88.0
/system identity
set name=PtMP-client1

Client2 SXT configuratie script

/interface bridge
add name=bridge1
/interface wireless
set [ find default-name=wlan1 ] band=5ghz-a/n/ac country=belgium disabled=no frequency=5680 mode=station-bridge nv2-preshared-key=testtest nv2-security=enabled ssid=MikroTik-nv2-PtMP
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/interface bridge port
add bridge=bridge1 interface=wlan1
add bridge=bridge1 interface=ether1
/ip address
add address=192.168.88.4/24 interface=wlan1 network=192.168.88.0
/ip route
add distance=1 gateway=192.168.88.1
/system identity
set name=PtMP-client2

Deze configuratie is een hulpmiddel om een Mikrotik nv2 configuratie te verwezenlijken. Denk er wel aan om een beter paswoord te gaan gebruiken om je draadloze link te beveiligen. Denk er ook aan dat je de default login wijzigt want deze is niet bijgewerkt. De landinstelling moet ook worden aangepast indien je je in een ander land bevindt. Ik kan nooit verantwoordelijk worden gesteld voor deze configuratie. 

Het ping resultaat van de Point to Multi Point nv2 configuratie

Ping resultaat

De ping resultaten zijn zeer bevredigend met deze Mikrotik nv2 configuratie is het niet? Binnenkort ga ik linktesten uitvoeren met deze configuratie. Ik hou je zeker op de hoogte en plaats de resultaten op deze blogpost. Er zijn nog parameters die je kan gaan instellen om de draadloze link nog meer te finetunen. 

In deze tutorial zie je een volledige point to point configuratie met twee Mikrotik SXT SQ 5 AC. Deze SXT's hebben een licentie 3 waardoor deze niet kunnen worden gebruikt als accespoint. Daarom laat ik je twee video's zien om een niet gekend probleem op te lossen. Ik wens je veel leer genot. 

De tweede video gaat ook over dezelfde point to point link door middel van het nv2 protocol. Dit is een andere aanpak dan de eerste video. Ik geef hier meer uitleg over het doen en laten van de configuratie. Dit vindt ik zeer belangrijk maar sommige mensen zien liever alleen de configuratie. Hierdoor kan je niet veel leren waarom en hoe je sommige parameters moet instellen. 

Wapen je Point to Point link tegen deauthenticatie aanvallen 

Een deauthenticatie aanval is niets anders dan de verbonden cliënt te laten loskoppelen van het accespoint. Dit door middel van het klonen van de MAC-adressen.
De aanval wordt ingezet door het accespoint deauthentication frames te zenden alsof deze van de cliënt afkomstig zijn. Het accespoint laat de verbinding los en de kwaadwillige kan daarna zijn aanval verder zetten. Doch Mikrotik heeft een manier ontworpen om deze aanvallen af te weren. RouterOS implementeert een eigen algoritme voor framebescherming. Dit door middel van een gedeeld paswoord die je moet gaan ingeven. De cliënt en accespoint moeten over dezelfde sleutel beschikken. Deze functie maakt het mogelijk om deauthenticatie en dissociatie aanvallen op RouterOS-gebaseerde draadloze apparaten te weerstaan.

Steun WirelessInfo.be

Om de onkosten van de hosting en plug-ins te helpen dragen geef een kleine bijdrage alstublieft.

Please follow and like us:

Deze website maakt gebruik van cookies. Door deze site te blijven gebruiken, accepteert u het gebruik van deze cookies.