Deel dit onderwerp alstublieft!

Mikrotik code hulp pagina

Met deze Mikrotik code hulp pagina wil ik hulp bieden aan iedereen die Mikrotik configuraties maakt. Dit door middel van exports te nemen. Ik plaats deze exports hier online. Zo hoef je zelf niet meer een export te nemen. Een voorbeeld hiervan is de default firewall. Na een reset zonder default configuratie kan je nadien de firewall terugplaatsen. Deze Mikrotik code kopieer en plak pagina wordt regelmatig uitgebreid. Neem daarom op regelmatige basis een kijkje op deze hulppagina. Indien je graag een code online ziet staan kan je me steeds contacteren via email. Ik hoop hiermee hulp te bieden zodat je Mikrotik configuratie vlotter verloopt. Meer weten over de Mikrotik configuraties? Bekijk ook deze blogpost. Ik plaats zowel code van Mikrotik routers en Mikrotik switches.  

De aangeboden code is compatibel met

RouterOS v6 en v7

De Mikrotik code kopieer en plak pagina is universeel inzetbaar 

Mikrotik code hulppagina

In de eerste plaats zeg ik dat je de code voor elk model Mikrotik router kan gebruiken omdat deze allemaal draaien op hetzelfde besturingssysteem. Namelijk RouterOS.  Doch soms zal je aanpassingen moeten maken. Hou dit alvast in gedachten.

Ik merk soms op dat het terugplaatsen van de default firewall veel vergeten wordt. Daarom mag de code van de default firewall niet ontbreken. Indien je uw router reset zonder default configuratie kan je direct aan de slag met het importeren van de default firewall. Doch je moet eerst 2 interface lists aanmaken, namelijk een WAN en een LAN interface list. Dit mag je zeker niet vergeten anders krijg je een foutmelding. De default interface list staat hier ook online. Wil je meer weten over de Mikrotik configuraties lees dan ook deze blogpost die ik voor jou heb gemaakt.

Hoe moet je de gekopieerde code importeren op je router 

Eerst reset je de router of switch zonder default configuratie. Dit is een voorwaarde om geen problemen te ondervinden. Indien je zelf al een gedeeltelijke configuratie hebt aangemaakt doe je dat niet. Je kopieert de Mikrotik code en opent new terminal op het Mikrotik toestel. Dit doe je het best door gebruik te maken van Winbox. Plak vervolgens de code in het new terminalvenster. Dit is alles wat je moet doen maar soms is dat niet voldoende. Je moet rekening houden met het volgende. Stel jezelf de vraag: Komen de interfaces overeen met de code? Hebben de interfaces dezelfde naam? Dit is zeer belangrijk om weten. Indien je moeilijkheden ondervindt stel jezelf de vraag of de interfaces overeenkomen en/of er interfaces ontbreken. Het new terminal venster kan je vinden in het Winbox menu zoals hieronder afgebeeld. 

Mikrotik code new terminal
Mikrotik code  hulppagina

Om deze beschikbare Mikrotik code te bewerken raad ik je aan om gebruik te maken van notepad++. Deze kan je hier downloaden op de officiële website of klik op het logo. Na de download installeer deze en je kan aan de slag.


De default Interface list

De Mikrotik interface list moet eerst worden ingevoerd op je Mikrotik router. Dit omdat de default firewall gebruikt maakt van deze interface lists. Dit is goed om weten want anders kan je de firewall niet terugplaatsen. Je krijgt namelijk een foutmelding te zien dat de interfaces niet overeenkomen. Daarom plaats ik deze Mikrotik code eerst.

/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=ether1 list=WAN

Default firewall 

De default firewall kan je terugplaatsen als je de bovenstaande interface list hebt geïmplementeerd. Dit komt omdat sommige firewall regels naar deze interface list verwijzen. Dit is zeer belangrijk en leg hier steeds de nadruk op. Meer weten over de Mikrotik firewall? Ik heb hier meerdere onderwerpen op mijn YouTube kanaal geplaatst. Indien deze video tutorials een hulp zijn voor je geef me alstublieft een thumbs up. En abonneer je op mijn YouTube kanaal.    

/ip firewall filter
add action=accept chain=input comment="defconf: accept established,related,untracked" connection-state=established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment="defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=drop chain=input comment="defconf: drop all not coming from LAN" in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" connection-state=established,related hw-offload=yes
add action=accept chain=forward comment="defconf: accept established,related, untracked" connection-state=established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
add action=drop chain=forward comment="defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" ipsec-policy=out,none out-interface-list=WAN

Bruikbare Mikrotik code voor de Mikrotik switchen

De Mikrotik switchen zoals de CRS3xx series zijn prachtige switchen. Het voordeel dat deze hebben is dat ze zijn uitgerust met één switch-chip. Hierdoor kan er ten volle gebruik worden gemaakt van HW-Offload. Wil je een configuratie van CRS326 samen met een router zien bekijk dan deze blogpost. Deze blogpost zal je meer duidelijkheid geven hoe deze te configureren. Ik plaats hier ook enkele codes zoals het aanmaken van de bridge en het toevoegen van al de interfaces. Ik raad ook aan om deze blogpost door te nemen over de Mikrotik CRS3xx serie VLAN configuratie.
Dit doe ik voor verschillende Mikrotik switchen die ik in mijn bezit heb.

CRS-328

Bridge en poort configuratie voor de CRS328-24G-4S+RM

Na een volledige reset om van de default configuratie af te zijn kan je deze onderstaande Mikrotik code kopiëren en plakken. Hiermee maak je één bridge aan en plaats je alle interfaces in deze bridge. Dit is tijd besparend en neemt je veel werk uit handen. Dit is de juiste manier om deze Mikrotik switchen te configureren met VLAN. Op deze manier kan je HW-Offload behouden op deze prachtige switchen. 

/interface bridge
add name=bridge1
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether5
add bridge=bridge1 interface=ether6
add bridge=bridge1 interface=ether7
add bridge=bridge1 interface=ether8
add bridge=bridge1 interface=ether9
add bridge=bridge1 interface=ether10
add bridge=bridge1 interface=ether11
add bridge=bridge1 interface=ether12
add bridge=bridge1 interface=ether13
add bridge=bridge1 interface=ether14
add bridge=bridge1 interface=ether15
add bridge=bridge1 interface=ether16
add bridge=bridge1 interface=ether17
add bridge=bridge1 interface=ether18
add bridge=bridge1 interface=ether19
add bridge=bridge1 interface=ether20
add bridge=bridge1 interface=ether21
add bridge=bridge1 interface=ether22
add bridge=bridge1 interface=ether23
add bridge=bridge1 interface=ether24
add bridge=bridge1 interface=sfp-sfpplus1
add bridge=bridge1 interface=sfp-sfpplus2
add bridge=bridge1 interface=sfp-sfpplus3
add bridge=bridge1 interface=sfp-sfpplus4

Configureren van DOT1x op de CRS328-24G-4S+RM

Met de onderstaande code maak je een interface list aan genaamd dot1x. De interfaces ether1 tot ether24 wordt aan deze list toegevoegd. Uiteraard kan je deze list gaan aanpassen. Opgelet! alle ethernet interfaces zijn in de DOT1x list geplaatst. Denk eraan dat je uw verbinding niet verliest doordat alle interfaces beveiligt gaan zijn. De SFP+ poorten zijn opzettelijk niet toegevoegd in deze dot1x list. Opgelet dit is geen complete dot1x configuratie. Dit is slechts een hulppagina bij het maken van tijdrovende configuraties.

/interface list
add name=dot1x
/interface list member
add interface=ether1 list=dot1x
add interface=ether2 list=dot1x
add interface=ether3 list=dot1x
add interface=ether4 list=dot1x
add interface=ether5 list=dot1x
add interface=ether6 list=dot1x
add interface=ether7 list=dot1x
add interface=ether8 list=dot1x
add interface=ether9 list=dot1x
add interface=ether10 list=dot1x
add interface=ether11 list=dot1x
add interface=ether12 list=dot1x
add interface=ether13 list=dot1x
add interface=ether14 list=dot1x
add interface=ether15 list=dot1x
add interface=ether16 list=dot1x
add interface=ether17 list=dot1x
add interface=ether18 list=dot1x
add interface=ether19 list=dot1x
add interface=ether20 list=dot1x
add interface=ether21 list=dot1x
add interface=ether22 list=dot1x
add interface=ether23 list=dot1x
add interface=ether24 list=dot1x

Mikrotik CRS 326

Bridge en poort configuratie voor de CRS326-24G-2S+RM

/interface bridge
add name=bridge1
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether5
add bridge=bridge1 interface=ether6
add bridge=bridge1 interface=ether7
add bridge=bridge1 interface=ether8
add bridge=bridge1 interface=ether9
add bridge=bridge1 interface=ether10
add bridge=bridge1 interface=ether11
add bridge=bridge1 interface=ether12
add bridge=bridge1 interface=ether13
add bridge=bridge1 interface=ether14
add bridge=bridge1 interface=ether15
add bridge=bridge1 interface=ether16
add bridge=bridge1 interface=ether17
add bridge=bridge1 interface=ether18
add bridge=bridge1 interface=ether19
add bridge=bridge1 interface=ether20
add bridge=bridge1 interface=ether21
add bridge=bridge1 interface=ether22
add bridge=bridge1 interface=ether23
add bridge=bridge1 interface=ether24
add bridge=bridge1 interface=sfp-sfpplus1
add bridge=bridge1 interface=sfp-sfpplus2

Configureren van DOT1x op de CRS326-24G-2S+RM

Met de onderstaande code maak je een interface list aan genaamd dot1x. De interfaces ether1 tot ether23 wordt aan deze list toegevoegd. Uiteraard kan je deze list gaan aanpassen. Ik heb opzettelijk de ethernet poort ether24 niet in deze list geplaatst zodat je nog steeds verbinding kan maken met de switch. Ook de SFP+ poorten zijn opzettelijk niet toegevoegd in deze dot1x list. Opgelet dit is geen complete dot1x configuratie. Dit is slechts een hulppagina bij het maken van tijdrovende configuraties.

/interface list
add name=dot1x
/interface list member
add interface=ether1 list=dot1x
add interface=ether2 list=dot1x
add interface=ether3 list=dot1x
add interface=ether4 list=dot1x
add interface=ether5 list=dot1x
add interface=ether6 list=dot1x
add interface=ether7 list=dot1x
add interface=ether8 list=dot1x
add interface=ether9 list=dot1x
add interface=ether10 list=dot1x
add interface=ether11 list=dot1x
add interface=ether12 list=dot1x
add interface=ether13 list=dot1x
add interface=ether14 list=dot1x
add interface=ether15 list=dot1x
add interface=ether16 list=dot1x
add interface=ether17 list=dot1x
add interface=ether18 list=dot1x
add interface=ether19 list=dot1x
add interface=ether20 list=dot1x
add interface=ether21 list=dot1x
add interface=ether22 list=dot1x
add interface=ether23 list=dot1x

Bridge en poort configuratie CRS309-1G-8S+IN

Met deze code maak je één bridge aan en plaats je alle interfaces in deze bridge. Dit is tijd besparend en neemt je veel werk uit handen. Dit is de juiste manier om deze Mikrotik switchen te configureren met VLAN. Op deze manier kan je HW-Offload behouden op deze prachtige switch met 8 SFP+ poorten. Meer weten over glasvezel? Lees dan mijn blogpost over glasvezel weetjes.

/interface bridge
add name=bridge1
/interface bridge port
add bridge=bridge1 interface=sfp-sfpplus1
add bridge=bridge1 interface=sfp-sfpplus2
add bridge=bridge1 interface=sfp-sfpplus3
add bridge=bridge1 interface=sfp-sfpplus4
add bridge=bridge1 interface=sfp-sfpplus5
add bridge=bridge1 interface=sfp-sfpplus6
add bridge=bridge1 interface=sfp-sfpplus7
add bridge=bridge1 interface=sfp-sfpplus8
add bridge=bridge1 interface=ether1

Configureren van DOT1x op de CRS309-1G-8S+IN

Bij het configureren van dot1x kan je gebruik maken van deze deze interface list. Hou wel rekening met de interface die niet in deze list is geplaatst ether1. Dit is om de toegankelijkheid van deze switch te garanderen. Zorg er dus voor dat je niet wordt buitengesloten op de switch. Pas deze list indien nodig aan volgens je configuratie.
Let op! Deze code maakt alleen een dot1x interface list aan.

/interface list
add name=dot1x
/interface list
add name=dot1x
/interface list member
add interface=sfp-sfpplus1 list=dot1x
add interface=sfp-sfpplus2 list=dot1x
add interface=sfp-sfpplus3 list=dot1x
add interface=sfp-sfpplus4 list=dot1x
add interface=sfp-sfpplus5 list=dot1x
add interface=sfp-sfpplus6 list=dot1x
add interface=sfp-sfpplus7 list=dot1x
add interface=sfp-sfpplus8 list=dot1x

Mikrotik crs305
Mikrotik CRS3xx hulppagina

Bridge en poort configuratie CRS305-1G-4S+IN

Ook deze Mikrotik switch CRS305-1G-4S+IN code mag niet ontbreken.  

/interface bridge
add name=bridge1
/interface bridge port
add bridge=bridge1 interface=sfp-sfpplus1
add bridge=bridge1 interface=sfp-sfpplus2
add bridge=bridge1 interface=sfp-sfpplus3
add bridge=bridge1 interface=sfp-sfpplus4
add bridge=bridge1 interface=ether1

Configureren van DOT1x op de CRS305-1G-4S+IN

Opgelet! deze Mikrotik code omvat niet de volledige dot1x configuratie. Deze code maakt een interface list aan genaamd dot1x en plaatst al de SFP+ poorten in deze list. Deze dot1x interface list kan je gebruiken bij je dot1x configuratie. Begrijp dit niet verkeerd.

/interface list
add name=dot1x
/interface list
add name=dot1x
/interface list member
add interface=sfp-sfpplus1 list=dot1x
add interface=sfp-sfpplus2 list=dot1x
add interface=sfp-sfpplus3 list=dot1x
add interface=sfp-sfpplus4 list=dot1x

Mikrotik CAPsMAN channel frequenties

De CAPsMAN wifi kanalen en de frequenties kunnen niet ontbreken in deze Mikrotik code hulp pagina. Het zal je zeker opvallen dat ik op de 2.4 GHz. maar 3 kanalen configureer. Dit is opzettelijk gedaan omdat er maar 3 bruikbare wifi kanalen zijn op de 2.4 GHz. Al de bijkomende kanalen overlappen elkaar wat resulteert in gestoorde kanalen. De 5 GHz. frequentie bestaat uit meerdere niet overlappende kanalen. Doch sommige van deze kanalen zijn gedeelde kanalen. Indien je hierover meer wil weten kan je steeds een kijkje nemen op een andere blogpost getiteld "wifi wetgeving". Het valt je misschien op dat ik voor de 20 MHz. bandbreedte ga. Dit is omdat 20 MHz. het meest wordt ondersteund door alle draadloze toestellen. Mikrotik CAPsMAN kan ook worden gebruikt met de nieuwe RouterOS v7. Je kan hier lezen wat de bijzondere wijzigingen zijn.

/caps-man channel
add band=2ghz-g/n control-channel-width=20mhz frequency=2412 name=channel1
add band=2ghz-g/n control-channel-width=20mhz frequency=2437 name=channel6
add band=2ghz-g/n control-channel-width=20mhz frequency=2462 name=channel11
add band=5ghz-n/ac comment="Indoor channels" control-channel-width=20mhz frequency=5180 name=channel36
add band=5ghz-n/ac control-channel-width=20mhz frequency=5200 name=channel40
add band=5ghz-n/ac control-channel-width=20mhz frequency=5220 name=channel44
add band=5ghz-n/ac control-channel-width=20mhz frequency=5240 name=channel48
add band=5ghz-n/ac control-channel-width=20mhz frequency=5260 name=channel52
add band=5ghz-n/ac control-channel-width=20mhz frequency=5280 name=channel56
add band=5ghz-n/ac control-channel-width=20mhz frequency=5300 name=channel60
add band=5ghz-n/ac control-channel-width=20mhz frequency=5320 name=channel64
add band=5ghz-n/ac comment="Outdoor channels" control-channel-width=20mhz frequency=5500 name=channel100
add band=5ghz-n/ac control-channel-width=20mhz frequency=5520 name=channel104
add band=5ghz-n/ac control-channel-width=20mhz frequency=5540 name=channel108
add band=5ghz-n/ac control-channel-width=20mhz frequency=5560 name=channel112
add band=5ghz-n/ac control-channel-width=20mhz frequency=5580 name=channel116
add band=5ghz-n/ac control-channel-width=20mhz frequency=5600 name=channel120
add band=5ghz-n/ac control-channel-width=20mhz frequency=5620 name=channel124
add band=5ghz-n/ac control-channel-width=20mhz frequency=5660 name=channel132
add band=5ghz-n/ac control-channel-width=20mhz frequency=5640 name=channel128
add band=5ghz-n/ac control-channel-width=20mhz frequency=5680 name=channel136

Blijf op de hoogte van nieuwe video tutorials



Please follow and like us:
Pin Share

Deze website maakt gebruik van cookies. Door deze site te blijven gebruiken, accepteert u het gebruik van deze cookies.